Permalink
Fetching contributors…
Cannot retrieve contributors at this time
133 lines (92 sloc) 6.8 KB
语言: 🇺🇸 🇨🇳 🇷🇺

e x T

«NexT» 是一款风格优雅的高质量 Hexo 主题,自点点滴滴中用爱雕琢而成。

即时预览

更多 «NexT» 的例子参见这里

安装

最简单的安装方式是直接克隆整个仓库:

$ cd hexo
$ git clone https://github.com/theme-next/hexo-theme-next themes/next

此外,如果你想要使用其他方式,你也可以参见详细安装步骤

插件

在 NexT 配置中你现在可以找到已经被移至外部仓库的依赖项。你可以在组织主页中找到它们。

例如,假设你想要在你的站点中使用 fancybox 插件,请进入 NexT 配置文件,你会看到如下内容:

# Fancybox
# Dependencies: https://github.com/theme-next/theme-next-fancybox
fancybox: false

fancybox 配置项打开,进入它上面的 «Dependencies» 链接以查看它的安装步骤。

例外

如果你使用的插件脚本依赖 CDN,那么需要替换你的 CDN 链接:

例如,假如你使用了 fancybox 插件并且配置了 CDN 加载链接,进入 Next 配置文件,你会看到如下内容:

vendors:
  # ...
  # Some contents...
  # ...
  fancybox: # Set or update fancybox cdn url.
  fancybox_css: # Set or update fancybox cdn url.

通过替换 CDN 链接来替换 插件列表 项目来升级。

更新

你可以通过如下命令更新到最新的 master 分支:

$ cd themes/next
$ git pull

如果你在此过程中收到了任何错误报告 (例如 «Commit your changes or stash them before you can merge»),我们推荐你使用 Hexo 数据文件特性。
然而你也可以通过提交(Commit)、贮藏(Stash)或忽视(Discard)本地更改以绕过这种更新错误。具体方法请参考这里

如果你想要从 v5.1.x 更新到 v6.0.x,阅读这篇文档

已知问题

对于仍然遇到 «Error: Cannot find module 'hexo-util'» 这一错误的用户,请检查你的 NPM 版本。

  • > 3:仍然出现错误吗?请删除 node_modules 目录并通过 npm install 重新安装。
  • < 3:请通过 npm install --save-dev hexo-utilhexo-util 依赖手动添加至你的站点依赖包中。

贡献你的代码

我们欢迎你贡献出你的一份力量,你可以随时提交 issue 或 fork 本仓库。静候你的 pull request。

Feedback

第三方應用程序