Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

IE11 compatibility issue with 6.7.0 Gemini. [solved] #587

Closed
uinika opened this issue Jan 16, 2019 · 23 comments

Comments

@uinika
Copy link

commented Jan 16, 2019

Expected behavior

Browser compatibility bug for IE11.

Actual behavior

Open the hexo-theme-next 6.7.0 website with IE11, unable to display content and layout dislocation.

NexT Information

NexT Version:

  • Latest Master branch
  • Latest Release version
  • Old version

NexT Scheme:

  • All schemes
  • Muse
  • Mist
  • Pisces
  • Gemini
@sli1989

This comment has been minimized.

Copy link
Collaborator

commented Jan 16, 2019

ivan-nginx commented on 13 Jan 2018

Old versions of IE (IE 11 too) not support by Microsoft from January 12, 2016. IE 11 was supported till 2015 year and for now it can't totally show all CSS3 styles (can't show shadow-borders in Gemini, transparents, etc.) and some JS features (sidebar in Pisces/Gemini, TOC, footer alignments).

Miscrosoft suggest to upgrade from IE to Edge, and Edge already support all new features above.
image

But if u still want to use IE, u can downdgrade NexT to version to 4.x or try to use any another simple theme with old css styles and without new JS features.

@uinika

This comment has been minimized.

Copy link
Author

commented Jan 16, 2019

企业实际生产环境当中,前端通常都会要求兼容至IE11,国内Win7 + IE11的用户占据全部PC用户的一半以上,这个是现实国情。如果这个项目总是按照团队偏好尝试使用CSS3的各类新特性,而不考虑最为基本的兼容性(保持布局基本可用,内容完整可见),我确实只能选择使用其它皮肤,毕竟我的博客并不仅仅是写来给拥有新版浏览器的用户阅读的。

@sli1989

This comment has been minimized.

Copy link
Collaborator

commented Jan 16, 2019

Thanks, We'll consider it with discretion.

@sli1989 sli1989 added the Discussion label Jan 16, 2019
@ivan-nginx

This comment has been minimized.

Copy link
Member

commented Jan 16, 2019

I don't understand why IE still un use by peoples...

@uinika

This comment has been minimized.

Copy link
Author

commented Jan 16, 2019

Some goverment and enterprise still choose IE11, because IE Edge must install Win10 that usually force-autoupdate and upload private info to the MS cloud. obviously, it's not controlled & safe !
Even though Chrome & FF has great user experience, but IE still has a lot of users. Especially some non-professional guys , don't ignore them.

@uinika uinika changed the title 最新的6.7.0在Gemini模式下,IE11浏览器下无法正常显示,建议正确处理IE11下的BUG。 IE11 compatibility issue with 6.7.0 Gemini. Jan 16, 2019
@ivan-nginx

This comment has been minimized.

Copy link
Member

commented Jan 16, 2019

So, can you try to switch to v6 branch and check IE11 compatability?


Also, what actually don't work with current master branch?

unable to display content and layout dislocation

Can you provide screens for this?

You can also check #30 issue, same behaviour?

@uinika

This comment has been minimized.

Copy link
Author

commented Jan 16, 2019

iexplore_2ptheuhpjf

Nothing to see in IE11, thanks for your attention.

@ivan-nginx

This comment has been minimized.

Copy link
Member

commented Jan 16, 2019

So, can you try to switch to v6 branch and check IE11 compatability?

Just switch branch from master to v6:

cd themes/next
git checkout v6.x

And try to repeat same steps.

@uinika

This comment has been minimized.

Copy link
Author

commented Jan 16, 2019

I always take below command to update my project.

λ git submodule update --remote

So there is no way to specify the exact version. but it works good when i take the checkout v6.7.0.
I think git submodule is more elegant than the git checkout, I suggesstion that push statble release into the master branch and push development code into the develop, it should be a best practice.

@ivan-nginx

This comment has been minimized.

Copy link
Member

commented Jan 16, 2019

If you want stable release version, you can read installation guide here: https://theme-next.org/docs/getting-started/installation/

@jiangtj

This comment has been minimized.

Copy link
Member

commented Jan 17, 2019

https://git-scm.com/book/zh/v2/Git-工具-子模块
You can go into submodule directory and check out branch
image
I'm using submodule too, and work in custom branch

@jiangtj

This comment has been minimized.

Copy link
Member

commented Jan 17, 2019

See this issue #567
This branching model is also best practice.
And gitlab use the similar branching model.
https://docs.gitlab.com/ee/university/training/gitlab_flow.html#release-branch
I love this!

@uinika

This comment has been minimized.

Copy link
Author

commented Jan 17, 2019

PLS refer to this article https://nvie.com/posts/a-successful-git-branching-model/, Git Flow more convenient when use with git submodule.
just sugestion, suit yourself.

@ivan-nginx

This comment has been minimized.

Copy link
Member

commented Jan 17, 2019

I see what title is «IE11 compatibility issue with 6.7.0 Gemini», but we talking about other things.

Issue solved or not? IE work fine?

@uinika

This comment has been minimized.

Copy link
Author

commented Jan 17, 2019

IE11 works fine when checkout 6.7.0 tag.

@ivan-nginx

This comment has been minimized.

Copy link
Member

commented Jan 17, 2019

But not work with master branch?

@jiangtj

This comment has been minimized.

Copy link
Member

commented Jan 17, 2019

Here is my blog about git-flow
Also referred to Vincent Driessen's branching model.
I don't like Vincent Driessen's branching model, duo to it maybe cause error when the operator is not careful

@uinika

This comment has been minimized.

Copy link
Author

commented Jan 17, 2019

@ivan-nginx
Yep, there seems to be a problem with the master branch, U can see my screenshot above.

@jiangtj

This comment has been minimized.

Copy link
Member

commented Jan 17, 2019

@uinika master branch as v7.x deploy branch, it no longer supports ie

@ivan-nginx

This comment has been minimized.

Copy link
Member

commented Jan 17, 2019

@uinika fix will soon, wait a little.

ivan-nginx added a commit that referenced this issue Jan 17, 2019
@ivan-nginx

This comment has been minimized.

Copy link
Member

commented Jan 17, 2019

@uinika check master branch now (update it).

@ivan-nginx ivan-nginx added Solved and removed Discussion labels Jan 17, 2019
@uinika

This comment has been minimized.

Copy link
Author

commented Jan 17, 2019

iexplore_5dfc7yicw0

Thanks for your help.

@ivan-nginx ivan-nginx closed this Jan 17, 2019
@ivan-nginx ivan-nginx changed the title IE11 compatibility issue with 6.7.0 Gemini. IE11 compatibility issue with 6.7.0 Gemini. [solved] Mar 4, 2019
@ivan-nginx ivan-nginx referenced this issue Mar 17, 2019
42 of 72 tasks complete
@ivan-nginx ivan-nginx referenced this issue Jul 17, 2019
16 of 35 tasks complete
@theme-next theme-next locked and limited conversation to collaborators Aug 28, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
5 participants
You can’t perform that action at this time.