Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

wolkenkit start fails on Ubuntu 16.04 #5

Closed
czosel opened this issue Jul 1, 2017 · 7 comments

Comments

Projects
None yet
2 participants
@czosel
Copy link

commented Jul 1, 2017

After setting up a new project with wolkenkit init on my Ubuntu 16.04 machine, wolkenkit start fails with the message
✗ Failed to create container chat-broker. Error response from daemon: invalid IP address in add-host: ""
I'm running docker v17.05.0-ce.

Any help is much appreciated!

@goloroden goloroden added the Bug label Jul 1, 2017

@goloroden

This comment has been minimized.

Copy link
Member

commented Jul 1, 2017

Thanks for bringing up this issue 😊

This seems to be a problem with the latest Docker versions.

If you setup a VM, e.g. using docker-machine, with 17.03 everything works as expected. We are investigating this issue, and will let you know once it has been fixed.

We have also experienced this behavior with 17.06 😢

@goloroden

This comment has been minimized.

Copy link
Member

commented Jul 1, 2017

PS: We have also reported this issue to the people from Docker, so it may be worth watching that thread as well.

@goloroden

This comment has been minimized.

Copy link
Member

commented Jul 1, 2017

Great news: We have found the issue and will release a new version of the CLI shortly…

@czosel

This comment has been minimized.

Copy link
Author

commented Jul 1, 2017

👍 awesome, thank you!

@goloroden

This comment has been minimized.

Copy link
Member

commented Jul 1, 2017

@czosel Could you please run:

$ wolkenkit update
$ wolkenkit --version

This should tell you that you are on 1.0.2.

If you then try to re-run wolkenkit start again - is the error gone?

@czosel

This comment has been minimized.

Copy link
Author

commented Jul 1, 2017

Yes, it's working now 😃 Thanks again for the prompt response!

@goloroden

This comment has been minimized.

Copy link
Member

commented Jul 1, 2017

You're welcome 😊

Then, I'm closing this issue.

@goloroden goloroden closed this Jul 1, 2017

@goloroden goloroden added the CLI label Nov 10, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.