OpenGL wrappers for LuaJIT
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
LICENSE
README
call.lua
fbo.lua
get.lua
gl.lua
gradienttex.lua
hsvtex.lua
intersect.lua
kernelprogram.lua
pingpong.lua
pingpong3d.lua
program.lua
report.lua
shader.lua
tex.lua
tex1d.lua
tex2d.lua
tex3d.lua
texcube.lua

README

Wrappers for OpenGL calls in LuaJIT

To use this with GLES2,
make sure LUA_PATH contains '?/?.lua'
use the following global to override the FFI file:
ffi_OpenGL = 'ffi.OpenGLES2'
require 'gl'

Make sure to use "require 'gl'" instead of "require 'ffi.OpenGL'" so prototype references can be handled properly

REQUIRES
- luajit
- lua-ext
- lua-ffi-bindings
- lua-template for showcode for GLShader
- lua-image for image loading / resizing in Tex2D