Permalink
Browse files

Properly require 5.006.

  • Loading branch information...
1 parent 8e54499 commit 1014d1235253b2a17bb60891833e0f13b50a64ad @theory committed Jun 23, 2008
Showing with 8 additions and 7 deletions.
  1. +1 −1 Build.PL
  2. +5 −5 META.yml
  3. +1 −1 Makefile.PL
  4. +1 −0 lib/Params/Callback.pm
View
@@ -16,7 +16,7 @@ my $build = Module::Build->new(
Test::Simple => '0.17',
Attribute::Handlers => '0.77',
Class::ISA => 0,
- perl => '5.6.0',
+ perl => 5.006,
},
);
$build->create_build_script;
View
@@ -1,6 +1,6 @@
---
name: Params-CallbackRequest
-version: 1.18
+version: 1.19
author:
- 'David Wheeler <david@kineticode.com>'
abstract: Functional and object-oriented callback architecture
@@ -15,7 +15,7 @@ requires:
Exception::Class: 1.10
Params::Validate: 0.59
Test::Simple: 0.17
- perl: 5.6.0
+ perl: 5.006
build_requires:
Module::Build: 0.2701
Test::More: 0.17
@@ -24,13 +24,13 @@ recommends:
provides:
Params::Callback:
file: lib/Params/Callback.pm
- version: 1.18
+ version: 1.19
Params::CallbackRequest:
file: lib/Params/CallbackRequest.pm
- version: 1.18
+ version: 1.19
Params::CallbackRequest::Exceptions:
file: lib/Params/CallbackRequest/Exceptions.pm
- version: 1.18
+ version: 1.19
generated_by: Module::Build version 0.280801
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.2.html
View
@@ -1,5 +1,5 @@
# Note: this file was auto-generated by Module::Build::Compat version 0.2808_01
-require 5.6.0;
+require 5.006;
unless (eval "use Module::Build::Compat 0.02; 1" ) {
print "This module requires Module::Build to install itself.\n";
@@ -1,6 +1,7 @@
package Params::Callback;
use strict;
+require 5.006;
use Params::Validate ();
use Params::CallbackRequest::Exceptions (abbr => [qw(throw_bad_params)]);

0 comments on commit 1014d12

Please sign in to comment.