Permalink
Browse files

Rename README to README.md and make it proper Markdown.

  • Loading branch information...
1 parent 310bcf3 commit e94623375b61e123766e486333515f93b8b4e09c @theory committed Jun 23, 2011
Showing with 24 additions and 21 deletions.
  1. +24 −21 README → README.md
View
45 README → README.md
@@ -3,10 +3,10 @@ Params/CallbackRequest version 1.20
Params::CallbackRequest provides functional and object-oriented callbacks to
method and function parameters. Callbacks may be either code references
-provided to the new() constructor, or methods defined in subclasses of
+provided to the `new()` constructor, or methods defined in subclasses of
Params::Callback. Callbacks are triggered either for every call to the
-Params::CallbackRequest C<execute()> method, or by specially named keys in the
-parameters to execute().
+Params::CallbackRequest `execute()` method, or by specially named keys in the
+parameters to `execute()`.
The idea behind this module is to provide a sort of plugin architecture for
Perl templating systems. Callbacks are executed by the contents of a request
@@ -16,42 +16,45 @@ from a form, to affect the contents of the request parameters before they're
passed to the templating system for processing, and even to redirect or abort
the request before the templating system handles it.
-INSTALLATION
+Installation
+------------
To install this module, type the following:
- perl Build.PL
- ./Build
- ./Build test
- ./Build install
+ perl Build.PL
+ ./Build
+ ./Build test
+ ./Build install
Or, if you don't have Module::Build installed, type the following:
- perl Makefile.PL
- make
- make test
- make install
+ perl Makefile.PL
+ make
+ make test
+ make install
-DEPENDENCIES
+Dependencies
+------------
This module requires these other modules and libraries:
- Params::Validate 0.59 or later
- Exception::Class 1.10 or later
+* Params::Validate 0.59 or later
+* Exception::Class 1.10 or later
The object-oriented callback interface requires Perl 5.6 or later and
these other modules and libraries:
- Attribute::Handlers 0.77 or later
- Class::ISA
+* Attribute::Handlers 0.77 or later
+* Class::ISA
The test suite requires:
- Test::Simple 0.17 or later
+* Test::Simple 0.17 or later
-COPYRIGHT AND LICENCE
+Copyright and License
+---------------------
Copyright 2003-2008 David Wheeler. Some Rights Reserved.
-This library is free software; you can redistribute it and/or modify
-it under the same terms as Perl itself.
+This library is free software; you can redistribute it and/or modify it under
+the same terms as Perl itself.

0 comments on commit e946233

Please sign in to comment.