Permalink
Browse files

Remove leading `:` from requires/conflicts in script templates.

Is is not needed anymore, since it is not parsed anymore.
  • Loading branch information...
theory committed Jun 26, 2012
1 parent 5d9932b commit 390ebc9134fc22c05b2688c97b23a1d6b1c2506b
Showing with 10 additions and 10 deletions.
  1. +2 −2 etc/templates/deploy.tmpl
  2. +1 −1 lib/sqitch-add-change.pod
  3. +3 −3 t/add_change.t
  4. +2 −2 t/pg/deploy/widgets.sql
  5. +1 −1 t/sql/deploy/users.sql
  6. +1 −1 t/sql/deploy/widgets.sql
@@ -1,9 +1,9 @@
-- Deploy [% change %]
[% FOREACH item IN requires -%]
--- :requires: [% item %]
+-- requires: [% item %]
[% END -%]
[% FOREACH item IN conflicts -%]
--- :conflicts: [% item %]
+-- conflicts: [% item %]
[% END -%]
BEGIN;
@@ -122,7 +122,7 @@ Conditional blocks:
Loop over a list of values:
[% FOREACH item IN requires -%]
- -- :requires: [% item %]
+ -- requires: [% item %]
[% END -%]
=back
View
@@ -236,9 +236,9 @@ is_deeply +MockOutput->get_info, [["Created $out"]],
'Info should show $out created';
file_contents_is $out, <<EOF, 'The template should have been evaluated with requires and conflicts';
-- Deploy another_change_test
--- :requires: foo
--- :requires: bar
--- :conflicts: baz
+-- requires: foo
+-- requires: bar
+-- conflicts: baz
BEGIN;
View
@@ -1,5 +1,5 @@
--- :requires: users
--- :conflicts: dr_evil
+-- requires: users
+-- conflicts: dr_evil
SET client_min_messages = warning;
CREATE TABLE __myapp.widgets (
name TEXT PRIMARY KEY,
View
@@ -1,2 +1,2 @@
-- Create users.
--- :requires: roles
+-- requires: roles
View
@@ -1,2 +1,2 @@
-- Create widgets.
--- :requires: users
+-- requires: users

0 comments on commit 390ebc9

Please sign in to comment.