New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SDK_OculusVRHeadset line 65 uses OVRPlugin.GetEyeVelocity which is no longer there #1169

Closed
olykken opened this Issue May 9, 2017 · 1 comment

Comments

2 participants
@olykken

olykken commented May 9, 2017

To recreate simply download the newest version of the Oculus SDK for Unity and import it into a blank project, then download the current version of VRTK. An error will immediately pop up saying "Assets/VRTK/SDK/OculusVR/SDK_OculusVRHeadset.cs(65,56): error CS0117: OVRPlugin' does not contain a definition forGetEyeVelocity'". I have been unable to find which version of the OVRPlugin that line of code was removed (or moved) but it cannot simply be added back in. That being said the GetEyeVelocity method is no longer there so that line of code will have to be changed (if that behavior is still needed).

edit: I discovered the version of the SDK_OculusVRHeadset here on GitHub is different from the one that is on the unity asset store. The appropriate fix can be found here.

@olykken olykken closed this May 9, 2017

@brucevang

This comment has been minimized.

Show comment
Hide comment
@brucevang

brucevang May 13, 2017

I had the same issue. Downloading the Github version fixed the Asset Store version. Thanks!

I had the same issue. Downloading the Github version fixed the Asset Store version. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment