Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Merge branch 'master' of github.com:thibaudgg/rspactor

Conflicts:
	CHANGELOG.rdoc
	Gemfile
  • Loading branch information...
commit 3e7589a1592f72bfe1a285a1a1b13af3ea285995 2 parents 1167a46 + 857c88b
Thibaud Guillaume-Gentil authored
2  Gemfile
View
@@ -1,3 +1,3 @@
source :rubygems
-gemspec
+gemspec
2  README.rdoc
View
@@ -7,7 +7,7 @@ Version 0.7.x is a complete rewrite, RubyCocoa is no more needed, FSEvents & Ino
- FSEvent support on Mac OS X (without RubyCocoa!)
- Inotify support on Linux
-- RSpec 1.x & 2.x (from beta.14) support
+- RSpec 1.x & 2.x (from beta.18) support
- Bundler support
- Super fast change detection
- Automatic _spec.rb files detection (even new file created, unlike watchr)
18 lib/formatters/rspec_two_formatter.rb
View
@@ -5,22 +5,12 @@
class RSpecTwoFormatter < RSpec::Core::Formatters::ProgressFormatter
include RSpecFormatter
- def dump_summary
- super
- message = rspactor_message(@example_count, failure_count, pending_count, format_seconds(duration))
- image_path = rspactor_image_path(failure_count, pending_count)
+ def dump_summary(duration, total, failures, pending)
+ super # needed to keep progress formatter
+ message = rspactor_message(total, failures, pending, duration)
+ image_path = rspactor_image_path(failures, pending)
RSpactor::Notifier.notify(message, rspactor_title, image_path)
end
-private
-
- def failure_count
- failed_examples.size
- end
-
- def pending_count
- pending_examples.size
- end
-
end
2  lib/rspactor/version.rb
View
@@ -1,3 +1,3 @@
module RSpactor
- VERSION = "0.7.0.beta.4"
+ VERSION = "0.7.0.beta.5"
end
2  rspactor.gemspec
View
@@ -16,7 +16,7 @@ Gem::Specification.new do |s|
s.rubyforge_project = "rspactor"
s.add_development_dependency 'bundler', '>= 1.0.0.rc.5'
- s.add_development_dependency 'rspec', '>= 2.0.0.beta.17'
+ s.add_development_dependency 'rspec', '>= 2.0.0.beta.19'
s.add_dependency 'bundler', '>= 1.0.0.rc.5'
s.add_dependency 'trollop', '>= 1.16.2'
Please sign in to comment.
Something went wrong with that request. Please try again.