Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Maintain backwards compatibility with Rails 3.1 #4

Merged
merged 1 commit into from

2 participants

@copyhacker

Only call super if Rails version is >= 3.2.

@copyhacker copyhacker Maintain backwards compatibility with Rails 3.1
Only call `super` if Rails version is >= 3.2.
831b278
@thickpaddy thickpaddy merged commit a059bd2 into thickpaddy:master
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jul 18, 2013
  1. @copyhacker

    Maintain backwards compatibility with Rails 3.1

    copyhacker authored
    Only call `super` if Rails version is >= 3.2.
This page is out of date. Refresh to see the latest.
Showing with 2 additions and 1 deletion.
  1. +2 −1  lib/ciunas/logger.rb
View
3  lib/ciunas/logger.rb
@@ -4,7 +4,8 @@ def initialize(app, opts = {})
@app = app
@opts = opts
@silenced = @opts.delete(:silenced) || []
- super
+
+ super if Rails::VERSION::STRING >= "3.2"
end
def call(env)
Something went wrong with that request. Please try again.