Skip to content
Browse files

Reorganize gemspec and Gemfile

  • Loading branch information...
1 parent d6650d1 commit e2745166c18554ec2ca7e2fa76033d4626356af1 @blt04 blt04 committed Apr 5, 2012
Showing with 21 additions and 32 deletions.
  1. +3 −0 Gemfile
  2. +1 −1 Rakefile
  3. +17 −31 authlogic_crowd.gemspec
View
3 Gemfile
@@ -2,3 +2,6 @@ source "http://rubygems.org"
# Specify your gem's dependencies in authlogic_crowd.gemspec
gemspec
+
+group :test do
+end
View
2 Rakefile
@@ -1,5 +1,5 @@
require 'rake'
-require 'rake/rdoctask'
+require 'rdoc/task'
require 'bundler'
Bundler::GemHelper.install_tasks
View
48 authlogic_crowd.gemspec
@@ -1,41 +1,27 @@
+# -*- encoding: utf-8 -*-
$:.push File.expand_path("../lib",__FILE__)
require 'authlogic_crowd/version'
Gem::Specification.new do |s|
- s.name = %q{authlogic_crowd}
- s.version = AuthlogicCrowd::VERSION.dup
- s.platform = Gem::Platform::RUBY
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Paul Strong"]
- s.description = %q{Authlogic Crowd}
- s.email = %q{paul@thestrongfamily.org}
- s.extra_rdoc_files = [
- "README.rdoc"
- ]
- s.files = %w(
- .document
- .gitignore
- Gemfile
- README.rdoc
- Rakefile
- authlogic_crowd.gemspec
- lib/authlogic_crowd.rb
- lib/authlogic_crowd/acts_as_authentic.rb
- lib/authlogic_crowd/acts_as_authentic_callbacks.rb
- lib/authlogic_crowd/session.rb
- lib/authlogic_crowd/session_callbacks.rb
- lib/authlogic_crowd/version.rb
- )
- s.homepage = %q{http://github.com/thinkwell/authlogic_crowd}
+ s.name = %q{authlogic_crowd}
+ s.version = AuthlogicCrowd::VERSION.dup
+ s.authors = ["Paul Strong"]
+ s.email = %q{paul@thestrongfamily.org}
+ s.homepage = %q{http://github.com/thinkwell/authlogic_crowd}
+ s.summary = %q{Atlassian Crowd support for Authlogic}
+ s.description = %q{Atlassian Crowd support for Authlogic}
+
+ s.rubyforge_project = "authlogic_crowd"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{Atlassian Crowd support for Authlogic}
- s.add_development_dependency(%q<thoughtbot-shoulda>, [">= 0"])
- s.add_development_dependency(%q<fcoury-matchy>, [">= 0"])
- s.add_development_dependency(%q<rr>, [">= 0"])
s.add_runtime_dependency(%q<authlogic>, [">= 2.1.3", "< 3.0.0"])
- s.add_runtime_dependency(%q<simple_crowd>, [">= 1.0.0"])
+ s.add_runtime_dependency(%q<simple_crowd>, [">= 1.1.0.pre"])
+ s.add_development_dependency(%q<bundler>, [">= 1.0.21"])
+ s.add_development_dependency(%q<rake>, [">= 0"])
end

0 comments on commit e274516

Please sign in to comment.
Something went wrong with that request. Please try again.