Permalink
Browse files

Use bundler to build gem instead of jeweler

  • Loading branch information...
1 parent 93866bb commit f3371939245e2d4da0e21e8a4908654a3717c43b @blt04 blt04 committed Oct 15, 2012
Showing with 30 additions and 206 deletions.
  1. +1 −0 .gitignore
  2. +2 −12 Gemfile
  3. +0 −68 Gemfile.lock
  4. +1 −45 Rakefile
  5. +0 −1 VERSION
  6. +3 −0 lib/mongoid_nested_set/version.rb
  7. +22 −79 mongoid_nested_set.gemspec
  8. +1 −1 spec/spec_helper.rb
View
@@ -1,3 +1,4 @@
+Gemfile.lock
# rcov generated
coverage
View
14 Gemfile
@@ -1,17 +1,7 @@
source "http://rubygems.org"
-gem "mongoid", ">= 3.0.0"
-
-# Add dependencies to develop your gem here.
-# Include everything needed to run rake, tests, features, etc.
-group :development do
- gem "bundler", "~> 1.0"
- gem "jeweler", "~> 1.5"
- gem "simplecov"
- gem "simplecov-rcov"
- gem 'rspec-core', "~> 2.0"
- gem 'rdoc'
-end
+# Specify your gem's dependencies in mongoid_nested_set.gemspec
+gemspec
group :test do
gem 'rspec-expectations', "~> 2.0"
View
@@ -1,68 +0,0 @@
-GEM
- remote: http://rubygems.org/
- specs:
- activemodel (3.2.6)
- activesupport (= 3.2.6)
- builder (~> 3.0.0)
- activesupport (3.2.6)
- i18n (~> 0.6)
- multi_json (~> 1.0)
- builder (3.0.0)
- diff-lcs (1.1.3)
- git (1.2.5)
- i18n (0.6.0)
- jeweler (1.8.4)
- bundler (~> 1.0)
- git (>= 1.2.5)
- rake
- rdoc
- json (1.7.3)
- mongoid (3.0.1)
- activemodel (~> 3.1)
- moped (~> 1.1.1)
- origin (~> 1.0.3)
- tzinfo (~> 0.3.22)
- moped (1.1.1)
- multi_json (1.3.6)
- origin (1.0.4)
- rake (0.9.2.2)
- rdoc (3.12)
- json (~> 1.4)
- remarkable (4.0.0.alpha4)
- rspec (>= 2.0.0.alpha11)
- remarkable_activemodel (4.0.0.alpha4)
- remarkable (~> 4.0.0.alpha4)
- rspec (>= 2.0.0.alpha11)
- remarkable_mongoid (0.6.0)
- remarkable_activemodel (~> 4.0.0.alpha4)
- rr (1.0.4)
- rspec (2.11.0)
- rspec-core (~> 2.11.0)
- rspec-expectations (~> 2.11.0)
- rspec-mocks (~> 2.11.0)
- rspec-core (2.11.0)
- rspec-expectations (2.11.1)
- diff-lcs (~> 1.1.3)
- rspec-mocks (2.11.1)
- simplecov (0.6.4)
- multi_json (~> 1.0)
- simplecov-html (~> 0.5.3)
- simplecov-html (0.5.3)
- simplecov-rcov (0.2.3)
- simplecov (>= 0.4.1)
- tzinfo (0.3.33)
-
-PLATFORMS
- ruby
-
-DEPENDENCIES
- bundler (~> 1.0)
- jeweler (~> 1.5)
- mongoid (>= 3.0.0)
- rdoc
- remarkable_mongoid
- rr
- rspec-core (~> 2.0)
- rspec-expectations (~> 2.0)
- simplecov
- simplecov-rcov
View
@@ -1,45 +1 @@
-require 'rubygems'
-require 'bundler'
-begin
- Bundler.setup(:default, :development)
-rescue Bundler::BundlerError => e
- $stderr.puts e.message
- $stderr.puts "Run `bundle install` to install missing gems"
- exit e.status_code
-end
-require 'rake'
-
-require 'jeweler'
-Jeweler::Tasks.new do |gem|
- # gem is a Gem::Specification... see http://docs.rubygems.org/read/chapter/20 for more options
- gem.name = "mongoid_nested_set"
- gem.homepage = "http://github.com/thinkwell/mongoid_nested_set"
- gem.license = "MIT"
- gem.summary = %Q{Nested set based tree implementation for Mongoid}
- gem.description = %Q{Fully featured tree implementation for Mongoid using the nested set model}
- gem.email = "bturner@bltweb.net"
- gem.authors = ["Brandon Turner"]
-end
-Jeweler::RubygemsDotOrgTasks.new
-
-require 'rspec/core/rake_task'
-RSpec::Core::RakeTask.new(:spec) do |spec|
- spec.pattern = FileList['spec/**/*_spec.rb']
-end
-
-task :rcov do
- ENV['COVERAGE'] = 'yes'
- Rake::Task["spec"].execute
-end
-
-task :default => :spec
-
-require 'rdoc/task'
-RDoc::Task.new do |rdoc|
- version = File.exist?('VERSION') ? File.read('VERSION') : ""
-
- rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "mongoid_nested_set #{version}"
- rdoc.rdoc_files.include('README*')
- rdoc.rdoc_files.include('lib/**/*.rb')
-end
+require 'bundler/gem_tasks'
View
@@ -1 +0,0 @@
-0.2.1
@@ -0,0 +1,3 @@
+module MongoidNestedSet
+ VERSION = "0.2.1"
+end
View
@@ -1,88 +1,31 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "mongoid_nested_set/version"
Gem::Specification.new do |s|
- s.name = "mongoid_nested_set"
- s.version = "0.2.1"
+ s.name = "mongoid_nested_set"
+ s.version = MongoidNestedSet::VERSION
+ s.authors = ["Brandon Turner"]
+ s.email = ["bt@brandonturner.net"]
+ s.homepage = "http://github.com/thinkwell/mongoid_nested_set"
+ s.summary = %q{Nested set based tree implementation for Mongoid}
+ s.description = %q{Fully featured tree implementation for Mongoid using the nested set model}
+ s.licenses = ["MIT"]
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Brandon Turner"]
- s.date = "2012-07-17"
- s.description = "Fully featured tree implementation for Mongoid using the nested set model"
- s.email = "bturner@bltweb.net"
- s.extra_rdoc_files = [
- "LICENSE.txt",
- "README.markdown"
- ]
- s.files = [
- ".document",
- ".rspec",
- "Gemfile",
- "Gemfile.lock",
- "LICENSE.txt",
- "README.markdown",
- "Rakefile",
- "VERSION",
- "lib/mongoid_nested_set.rb",
- "lib/mongoid_nested_set/base.rb",
- "lib/mongoid_nested_set/document.rb",
- "lib/mongoid_nested_set/fields.rb",
- "lib/mongoid_nested_set/outline_number.rb",
- "lib/mongoid_nested_set/rebuild.rb",
- "lib/mongoid_nested_set/relations.rb",
- "lib/mongoid_nested_set/remove_order_by.rb",
- "lib/mongoid_nested_set/update.rb",
- "lib/mongoid_nested_set/validation.rb",
- "mongoid_nested_set.gemspec",
- "spec/matchers/nestedset_pos.rb",
- "spec/models/circle_node.rb",
- "spec/models/node.rb",
- "spec/models/node_without_nested_set.rb",
- "spec/models/numbering_node.rb",
- "spec/models/renamed_fields.rb",
- "spec/models/shape_node.rb",
- "spec/models/square_node.rb",
- "spec/models/test_document.rb",
- "spec/models/unscoped_node.rb",
- "spec/mongoid_nested_set_spec.rb",
- "spec/spec_helper.rb"
- ]
- s.homepage = "http://github.com/thinkwell/mongoid_nested_set"
- s.licenses = ["MIT"]
+ s.rubyforge_project = "mongoid_nested_set"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.rubygems_version = "1.8.11"
- s.summary = "Nested set based tree implementation for Mongoid"
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ # specifiy any dependencies here; for example:
+ # s.add_development_dependency "rspec"
+ s.add_runtime_dependency(%q<mongoid>, [">= 3.0.0"])
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<mongoid>, [">= 3.0.0"])
- s.add_development_dependency(%q<bundler>, ["~> 1.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.5"])
- s.add_development_dependency(%q<simplecov>, [">= 0"])
- s.add_development_dependency(%q<simplecov-rcov>, [">= 0"])
- s.add_development_dependency(%q<rspec-core>, ["~> 2.0"])
- s.add_development_dependency(%q<rdoc>, [">= 0"])
- else
- s.add_dependency(%q<mongoid>, [">= 3.0.0"])
- s.add_dependency(%q<bundler>, ["~> 1.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5"])
- s.add_dependency(%q<simplecov>, [">= 0"])
- s.add_dependency(%q<simplecov-rcov>, [">= 0"])
- s.add_dependency(%q<rspec-core>, ["~> 2.0"])
- s.add_dependency(%q<rdoc>, [">= 0"])
- end
- else
- s.add_dependency(%q<mongoid>, [">= 3.0.0"])
- s.add_dependency(%q<bundler>, ["~> 1.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5"])
- s.add_dependency(%q<simplecov>, [">= 0"])
- s.add_dependency(%q<simplecov-rcov>, [">= 0"])
- s.add_dependency(%q<rspec-core>, ["~> 2.0"])
- s.add_dependency(%q<rdoc>, [">= 0"])
- end
+ s.add_development_dependency(%q<rspec>, [">= 2.7.0"])
+ s.add_development_dependency(%q<bundler>, [">= 1.0.21"])
+ s.add_development_dependency(%q<simplecov>)
+ s.add_development_dependency(%q<simplecov-rcov>)
end
View
@@ -29,7 +29,7 @@ module Mongoid::Acts::NestedSet::Matchers
Dir["#{File.dirname(__FILE__)}/matchers/*.rb"].each {|file| require file }
Mongoid.configure do |config|
- config.connect_to("dmongoid_nested_set_test")
+ config.connect_to("mongoid_nested_set_test")
config.allow_dynamic_fields = false
end

0 comments on commit f337193

Please sign in to comment.