Permalink
Fetching contributors…
Cannot retrieve contributors at this time
55 lines (45 sloc) 1.7 KB

Installation

pip install pytablewriter

Some of the formats require additional dependency packages, you can install the dependency packages as follows:

  • Elasticsearch
    • pip install pytablewriter[es6] or pip install pytablewriter[es5]
  • Excel
    • pip install pytablewriter[excel]
  • SQLite
    • pip install pytablewriter[sqlite]
  • TOML
    • pip install pytablewriter[toml]
  • All of the extra dependencies
    • pip install pytablewriter[all]

Dependencies

Python 2.7+ or 3.4+

Optional dependencies

Test dependencies