Skip to content
Permalink
Browse files

Consolidate requirements for Ruby 1.8.7

This will make it easy to update the dependency in the future.
  • Loading branch information...
sikachu committed Nov 14, 2016
1 parent b5aa3bd commit 3c9181b9529cc76734981c17b736baa1f9749dd3
Showing with 10 additions and 14 deletions.
  1. +3 −6 Gemfile
  2. +5 −0 Gemfile-1.8
  3. +1 −4 spec/acceptance/bundle_with_custom_path_spec.rb
  4. +1 −4 spec/support/acceptance_test_helpers.rb
@@ -1,13 +1,10 @@
source 'https://rubygems.org'
source "https://rubygems.org"

gemspec

# This here to make sure appraisal works with Rails 3.0.0.
gem 'thor', '~> 0.14.0'
gem "thor", "~> 0.14.0"

if RUBY_VERSION < "1.9"
gem "i18n", "~> 0.6.0"
gem "activesupport", "~> 3.2.21"
gem "rake", "~> 10.5"
gem "rack", "~> 1.6.5"
eval File.read("Gemfile-1.8")
end
@@ -0,0 +1,5 @@
# These gems are locked for Ruby 1.8.7 compatibility
gem "i18n", "~> 0.6.0"
gem "activesupport", "~> 3.2.21"
gem "rake", "~> 10.5"
gem "rack", "~> 1.6.5"
@@ -41,10 +41,7 @@
gem 'appraisal', :path => #{PROJECT_ROOT.inspect}
if RUBY_VERSION < "1.9"
gem "i18n", "~> 0.6.0"
gem "activesupport", "~> 3.2.21"
gem "rake", "~> 10.5"
gem "rack", "~> 1.6.5"
#{File.read(File.join(PROJECT_ROOT, "Gemfile-1.8"))}
end
Gemfile

@@ -142,10 +142,7 @@ def build_default_gemfile
gem 'appraisal', :path => '#{PROJECT_ROOT}'
if RUBY_VERSION < "1.9"
gem "i18n", "~> 0.6.0"
gem "activesupport", "~> 3.2.21"
gem "rake", "~> 10.5"
gem "rack", "~> 1.6.5"
#{File.read(File.join(PROJECT_ROOT, "Gemfile-1.8"))}
end
Gemfile

0 comments on commit 3c9181b

Please sign in to comment.
You can’t perform that action at this time.