Skip to content
Browse files

Fix gemspec

This updates the gemspec to use a verson of Jasmine that works correctly
so rake jasmine:ci runs.
  • Loading branch information...
1 parent e21cbf0 commit 79628e726f31d3d20759fc6c6f76a0f984981c29 @joshuaclayton joshuaclayton committed Mar 8, 2013
Showing with 39 additions and 31 deletions.
  1. +2 −4 Gemfile
  2. +34 −26 Gemfile.lock
  3. +3 −1 backbone-support.gemspec
View
6 Gemfile
@@ -1,5 +1,3 @@
-source :rubygems
+source 'https://rubygems.org'
-gem 'jasmine'
-gem 'headless'
-gem 'rake'
+gemspec
View
60 Gemfile.lock
@@ -1,38 +1,46 @@
+PATH
+ remote: .
+ specs:
+ backbone-support (0.3.1)
+
GEM
- remote: http://rubygems.org/
+ remote: https://rubygems.org/
specs:
- childprocess (0.2.0)
- ffi (~> 1.0.6)
- diff-lcs (1.1.2)
- ffi (1.0.9)
- headless (0.1.0)
- jasmine (1.0.2.1)
- json_pure (>= 1.4.3)
- rack (>= 1.1)
+ childprocess (0.3.9)
+ ffi (~> 1.0, >= 1.0.11)
+ diff-lcs (1.2.1)
+ ffi (1.4.0)
+ headless (1.0.1)
+ jasmine (1.3.0)
+ jasmine-core (>= 1.3.0)
+ rack (~> 1.0)
rspec (>= 1.3.1)
selenium-webdriver (>= 0.1.3)
- json_pure (1.5.3)
- rack (1.3.2)
- rake (0.9.2)
- rspec (2.6.0)
- rspec-core (~> 2.6.0)
- rspec-expectations (~> 2.6.0)
- rspec-mocks (~> 2.6.0)
- rspec-core (2.6.4)
- rspec-expectations (2.6.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.6.0)
- rubyzip (0.9.4)
- selenium-webdriver (2.3.2)
- childprocess (>= 0.1.9)
- ffi (>= 1.0.7)
- json_pure
+ jasmine-core (1.3.1)
+ multi_json (1.6.1)
+ rack (1.5.2)
+ rake (10.0.3)
+ rspec (2.13.0)
+ rspec-core (~> 2.13.0)
+ rspec-expectations (~> 2.13.0)
+ rspec-mocks (~> 2.13.0)
+ rspec-core (2.13.0)
+ rspec-expectations (2.13.0)
+ diff-lcs (>= 1.1.3, < 2.0)
+ rspec-mocks (2.13.0)
+ rubyzip (0.9.9)
+ selenium-webdriver (2.31.0)
+ childprocess (>= 0.2.5)
+ multi_json (~> 1.0)
rubyzip
+ websocket (~> 1.0.4)
+ websocket (1.0.7)
PLATFORMS
ruby
DEPENDENCIES
+ backbone-support!
headless
- jasmine
+ jasmine (= 1.3.0)
rake
View
4 backbone-support.gemspec
@@ -16,5 +16,7 @@ Gem::Specification.new do |s|
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.add_development_dependency('jasmine')
+ s.add_development_dependency('jasmine', '1.3.0')
+ s.add_development_dependency('rake')
+ s.add_development_dependency('headless')
end

0 comments on commit 79628e7

Please sign in to comment.
Something went wrong with that request. Please try again.