Skip to content
Permalink
Browse files

Unify stylelint version, ignore from Dependabot

This locks stylelint to specific versions and ignore it from Dependabot
so that it doesn't automatically open Pull Requests to update them.

The reason is because Hound has a specific version of stylelint that it
runs, and so while we might be using v12 of stylelint locally, Hound is
running v10 in our Pull Requests and so the results can differ.

Hound publishes their [supported linter versions][supported-linters]
and we can configure Hound to use specific versions via its `.hound.yml`
config.

Since these are just development tools, I think its probably fine for
them to be updated manually and less frequent than with Dependabot.

[supported-linters]: http://help.houndci.com/en/articles/2461415-supported-linters
  • Loading branch information
tysongach committed Mar 16, 2020
1 parent b5257ad commit 02e0e8eb3c029a49474fa190cfeef1f192ab3883
Showing with 10 additions and 2 deletions.
  1. +8 −0 .dependabot/config.yml
  2. +2 −2 package.json
@@ -0,0 +1,8 @@
version: 1
update_configs:
- package_manager: "javascript"
directory: "/"
update_schedule: "weekly"
ignored_updates:
- match:
dependency_name: "*stylelint*"
@@ -21,11 +21,11 @@
"url": "https://github.com/thoughtbot/bitters/issues"
},
"devDependencies": {
"@thoughtbot/stylelint-config": "^1.1.0",
"@thoughtbot/stylelint-config": "1.1.0",
"bourbon": "^6.0.0",
"parcel-bundler": "^1.12.4",
"sass": "^1.23.0",
"stylelint": "^10.1.0"
"stylelint": "10.1.0"
},
"scripts": {
"contrib": "npx parcel contrib/index.html --out-dir contrib/build",

0 comments on commit 02e0e8e

Please sign in to comment.
You can’t perform that action at this time.