Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Require Sass only when it's necessary

This will fix the problem on using sass from the command line in the
environment that `sass` gem is not available.
  • Loading branch information...
commit a70e94b1c450fc01a8d802b142147a944abc8a8c 1 parent 4486361
@sikachu sikachu authored plapier committed
Showing with 4 additions and 2 deletions.
  1. +4 −2 lib/bourbon/sass_extensions.rb
View
6 lib/bourbon/sass_extensions.rb
@@ -1,6 +1,8 @@
module Bourbon::SassExtensions
end
-require "sass"
+unless defined?(Sass)
+ require 'sass'
+end
-require File.join(File.dirname(__FILE__), "/sass_extensions/functions")
+require File.join(File.dirname(__FILE__), '/sass_extensions/functions')
Please sign in to comment.
Something went wrong with that request. Please try again.