Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

update mocha dependency #19

Closed
wants to merge 1 commit into from

2 participants

@frodsan

No description provided.

@joshuaclayton

Just pushed Bourne 1.3 (http://rubygems.org/gems/bourne/versions/1.3.0), which updates the dependency on mocha: 298b30c. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Nov 18, 2012
  1. @frodsan

    update mocha dependency

    frodsan authored
This page is out of date. Refresh to see the latest.
View
2  bourne.gemspec
@@ -20,7 +20,7 @@ Gem::Specification.new do |s|
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.add_dependency('mocha', '0.12.7') # follow instructions in mock.rb to update
+ s.add_dependency('mocha', '0.13.0') # follow instructions in mock.rb to update
s.add_development_dependency('rake')
end
View
2  test/test_helper.rb
@@ -14,7 +14,7 @@
end
require 'test/unit'
-require 'mocha'
+require 'mocha/setup'
if defined?(MiniTest)
FailedAssertion = MiniTest::Assertion
View
4 test/unit/assert_received_test.rb
@@ -2,7 +2,9 @@
require 'test_runner'
require 'bourne/api'
require 'bourne/mockery'
-require 'mocha/object'
+require 'mocha/object_methods'
+require 'mocha/module_methods'
+require 'mocha/class_methods'
class AssertReceivedTest < Test::Unit::TestCase
View
4 test/unit/have_received_test.rb
@@ -2,7 +2,9 @@
require 'test_runner'
require 'bourne/api'
require 'bourne/mockery'
-require 'mocha/object'
+require 'mocha/object_methods'
+require 'mocha/module_methods'
+require 'mocha/class_methods'
require 'matcher_helpers'
module HaveReceivedTestMethods
Something went wrong with that request. Please try again.