Skip to content
This repository
Browse code

Choose platform more reliably. (Works with Jruby.)

  • Loading branch information...
commit 0979db4675a50f0ca7ee232916a4afde49be02e4 1 parent 7f907a0
authored October 21, 2011 halogenandtoast committed January 13, 2012

Showing 1 changed file with 2 additions and 1 deletion. Show diff stats Hide diff stats

  1. 3  lib/capybara_webkit_builder.rb
3  lib/capybara_webkit_builder.rb
... ...
@@ -1,4 +1,5 @@
1 1
 require "fileutils"
  2
+require "rbconfig"
2 3
 
3 4
 module CapybaraWebkitBuilder
4 5
   extend self
@@ -11,7 +12,7 @@ def make_bin
11 12
   def makefile
12 13
     qmake_binaries = ['qmake', 'qmake-qt4']
13 14
     qmake = qmake_binaries.detect { |qmake| system("which #{qmake}") }
14  
-    case RUBY_PLATFORM
  15
+    case RbConfig::CONFIG['host_os']
15 16
     when /linux/
16 17
       system("#{qmake} -spec linux-g++")
17 18
     when /freebsd/

0 notes on commit 0979db4

Please sign in to comment.
Something went wrong with that request. Please try again.