Permalink
Browse files

Bump to 0.8.0; add json as a dependency

  • Loading branch information...
1 parent 2285621 commit 59ba8611ba6388cf5262eb31ec06cea34fa66698 @jferris jferris committed Jan 20, 2012
Showing with 28 additions and 21 deletions.
  1. +12 −10 Gemfile.lock
  2. +1 −0 capybara-webkit.gemspec
  3. +7 −5 gemfiles/1.0.gemfile.lock
  4. +7 −5 gemfiles/1.1.gemfile.lock
  5. +1 −1 lib/capybara/driver/webkit/version.rb
View
@@ -1,30 +1,32 @@
PATH
remote: .
specs:
- capybara-webkit (0.7.2)
+ capybara-webkit (0.8.0)
capybara (>= 1.0.0, < 1.2)
+ json
GEM
remote: http://rubygems.org/
specs:
appraisal (0.4.0)
bundler
rake
- capybara (1.1.1)
+ capybara (1.1.2)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
- childprocess (0.2.2)
+ childprocess (0.2.3)
ffi (~> 1.0.6)
diff-lcs (1.1.2)
- ffi (1.0.9)
- json_pure (1.6.1)
- mime-types (1.16)
+ ffi (1.0.11)
+ json (1.6.3)
+ mime-types (1.17.2)
mini_magick (3.2.1)
subexec (~> 0.0.4)
+ multi_json (1.0.4)
nokogiri (1.5.0)
rack (1.3.2)
rack-test (0.6.1)
@@ -38,11 +40,11 @@ GEM
rspec-expectations (2.6.0)
diff-lcs (~> 1.1.2)
rspec-mocks (2.6.0)
- rubyzip (0.9.4)
- selenium-webdriver (2.7.0)
+ rubyzip (0.9.5)
+ selenium-webdriver (2.15.0)
childprocess (>= 0.2.1)
- ffi (>= 1.0.7)
- json_pure
+ ffi (~> 1.0.9)
+ multi_json (~> 1.0.4)
rubyzip
sinatra (1.1.2)
rack (~> 1.1)
View
@@ -16,6 +16,7 @@ Gem::Specification.new do |s|
s.extensions = "extconf.rb"
s.add_runtime_dependency("capybara", [">= 1.0.0", "< 1.2"])
+ s.add_runtime_dependency("json")
s.add_development_dependency("rspec", "~> 2.6.0")
s.add_development_dependency("sinatra")
View
@@ -1,8 +1,9 @@
PATH
- remote: /Users/gabe/thoughtbot/capybara-webkit
+ remote: /Users/jferris/Source/capybara-webkit
specs:
- capybara-webkit (0.7.2)
+ capybara-webkit (0.8.0)
capybara (>= 1.0.0, < 1.2)
+ json
GEM
remote: http://rubygems.org/
@@ -21,6 +22,7 @@ GEM
ffi (~> 1.0.6)
diff-lcs (1.1.3)
ffi (1.0.10)
+ json (1.6.3)
json_pure (1.6.1)
mime-types (1.17.2)
mini_magick (3.3)
@@ -47,9 +49,9 @@ GEM
json_pure
rubyzip
sinatra (1.3.1)
- rack (>= 1.3.4, ~> 1.3)
- rack-protection (>= 1.1.2, ~> 1.1)
- tilt (>= 1.3.3, ~> 1.3)
+ rack (~> 1.3, >= 1.3.4)
+ rack-protection (~> 1.1, >= 1.1.2)
+ tilt (~> 1.3, >= 1.3.3)
subexec (0.1.0)
tilt (1.3.3)
xpath (0.1.4)
View
@@ -1,8 +1,9 @@
PATH
- remote: /Users/gabe/thoughtbot/capybara-webkit
+ remote: /Users/jferris/Source/capybara-webkit
specs:
- capybara-webkit (0.7.2)
+ capybara-webkit (0.8.0)
capybara (>= 1.0.0, < 1.2)
+ json
GEM
remote: http://rubygems.org/
@@ -21,6 +22,7 @@ GEM
ffi (~> 1.0.6)
diff-lcs (1.1.3)
ffi (1.0.10)
+ json (1.6.3)
json_pure (1.6.1)
mime-types (1.17.2)
mini_magick (3.3)
@@ -47,9 +49,9 @@ GEM
json_pure
rubyzip
sinatra (1.3.1)
- rack (>= 1.3.4, ~> 1.3)
- rack-protection (>= 1.1.2, ~> 1.1)
- tilt (>= 1.3.3, ~> 1.3)
+ rack (~> 1.3, >= 1.3.4)
+ rack-protection (~> 1.1, >= 1.1.2)
+ tilt (~> 1.3, >= 1.3.3)
subexec (0.1.0)
tilt (1.3.3)
xpath (0.1.4)
@@ -1,7 +1,7 @@
module Capybara
module Driver
class Webkit
- VERSION = '0.7.2'.freeze
+ VERSION = '0.8.0'.freeze
end
end
end

4 comments on commit 59ba861

Why? Any issues with stdlib's JSON?

Owner

jferris replied Jan 25, 2012

Why not raising an exception when require "json" fails on 1.8? Why force everyone using the stable version of Ruby (1.9) to install a gem?

Owner

jferris replied Jan 26, 2012

Please sign in to comment.