Skip to content
Browse files

Use Bundler gem conventions.

Add VERSION constant. Use latest version of appraisal.
  • Loading branch information...
1 parent 9971edb commit 6ba9dcbf2b0bcab48cd971ec4fc8fe981625bf38 @gabebw gabebw committed Nov 11, 2011
Showing with 68 additions and 71 deletions.
  1. +1 −6 Gemfile
  2. +2 −2 Gemfile.lock
  3. +3 −21 Rakefile
  4. +20 −14 capybara-webkit.gemspec
  5. +17 −14 gemfiles/1.0.gemfile.lock
  6. +17 −14 gemfiles/1.1.gemfile.lock
  7. +1 −0 lib/capybara/driver/webkit.rb
  8. +7 −0 lib/capybara/driver/webkit/version.rb
View
7 Gemfile
@@ -1,8 +1,3 @@
source "http://rubygems.org"
+
gemspec
-# gem "appraisal"
-# gem "rspec", '~> 2.6.0', :require => false
-# gem "capybara"
-# gem "sinatra", :require => false
-# gem "mini_magick", :require => false
-# gem 'rake'
View
4 Gemfile.lock
@@ -7,7 +7,7 @@ PATH
GEM
remote: http://rubygems.org/
specs:
- appraisal (0.3.8)
+ appraisal (0.4.0)
bundler
rake
capybara (1.1.1)
@@ -56,7 +56,7 @@ PLATFORMS
ruby
DEPENDENCIES
- appraisal
+ appraisal (~> 0.4.0)
capybara-webkit!
mini_magick
rake
View
24 Rakefile
@@ -1,10 +1,10 @@
-require 'rubygems'
-require 'bundler/setup'
+require 'bundler'
require 'rspec/core/rake_task'
-require 'rake/gempackagetask'
require 'capybara_webkit_builder'
require 'appraisal'
+Bundler::GemHelper.install_tasks
+
desc "Generate a Makefile using qmake"
file 'Makefile' do
CapybaraWebkitBuilder.makefile or exit(1)
@@ -30,24 +30,6 @@ end
desc "Default: build and run all specs"
task :default => [:build, :spec]
-eval("$specification = begin; #{IO.read('capybara-webkit.gemspec')}; end")
-Rake::GemPackageTask.new($specification) do |package|
- package.need_zip = true
- package.need_tar = true
-end
-
-gem_file = "pkg/#{$specification.name}-#{$specification.version}.gem"
-
-desc "Build and install the latest gem"
-task :install => :gem do
- sh("gem install --local #{gem_file}")
-end
-
-desc "Build and release the latest gem"
-task :release => :gem do
- sh("gem push #{gem_file}")
-end
-
desc "Generate a new command called NAME"
task :generate_command do
name = ENV['NAME'] or raise "Provide a name with NAME="
View
34 capybara-webkit.gemspec
@@ -1,20 +1,26 @@
+$:.push File.expand_path("../lib", __FILE__)
+require "capybara/driver/webkit/version"
+
Gem::Specification.new do |s|
- s.name = "capybara-webkit"
- s.version = "0.7.2"
- s.authors = ["thoughtbot", "Joe Ferris", "Matt Mongeau", "Mike Burns", "Jason Morrison"]
- s.email = "support@thoughtbot.com"
- s.files = `git ls-files`.split("\n")
- s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
+ s.name = "capybara-webkit"
+ s.version = Capybara::Driver::Webkit::VERSION.dup
+ s.authors = ["thoughtbot", "Joe Ferris", "Matt Mongeau", "Mike Burns", "Jason Morrison"]
+ s.email = "support@thoughtbot.com"
s.homepage = "http://github.com/thoughtbot/capybara-webkit"
+ s.summary = "Headless Webkit driver for Capybara"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
s.require_path = "lib"
- s.rubygems_version = "1.3.5"
- s.summary = "Headless Webkit driver for Capybara"
- s.add_runtime_dependency "capybara", [">= 1.0.0", "< 1.2"]
- s.add_development_dependency "rspec", "~> 2.6.0"
- s.add_development_dependency "sinatra"
- s.add_development_dependency "mini_magick"
- s.add_development_dependency "rake"
- s.add_development_dependency "appraisal"
+
s.extensions = "extconf.rb"
+
+ s.add_runtime_dependency("capybara", [">= 1.0.0", "< 1.2"])
+
+ s.add_development_dependency("rspec", "~> 2.6.0")
+ s.add_development_dependency("sinatra")
+ s.add_development_dependency("mini_magick")
+ s.add_development_dependency("rake")
+ s.add_development_dependency("appraisal", "~> 0.4.0")
end
View
31 gemfiles/1.0.gemfile.lock
@@ -1,13 +1,13 @@
PATH
- remote: /Users/jferris/Source/capybara-webkit
+ remote: /Users/gabe/thoughtbot/capybara-webkit
specs:
- capybara-webkit (0.6.1)
- capybara (< 1.2, >= 1.0.0)
+ capybara-webkit (0.7.2)
+ capybara (>= 1.0.0, < 1.2)
GEM
remote: http://rubygems.org/
specs:
- appraisal (0.3.8)
+ appraisal (0.4.0)
bundler
rake
capybara (1.0.1)
@@ -20,16 +20,18 @@ GEM
childprocess (0.2.2)
ffi (~> 1.0.6)
diff-lcs (1.1.3)
- ffi (1.0.9)
+ ffi (1.0.10)
json_pure (1.6.1)
- mime-types (1.16)
+ mime-types (1.17.2)
mini_magick (3.3)
subexec (~> 0.1.0)
nokogiri (1.5.0)
- rack (1.3.3)
+ rack (1.3.5)
+ rack-protection (1.1.4)
+ rack
rack-test (0.6.1)
rack (>= 1.0)
- rake (0.9.2)
+ rake (0.9.2.2)
rspec (2.6.0)
rspec-core (~> 2.6.0)
rspec-expectations (~> 2.6.0)
@@ -39,14 +41,15 @@ GEM
diff-lcs (~> 1.1.2)
rspec-mocks (2.6.0)
rubyzip (0.9.4)
- selenium-webdriver (2.7.0)
+ selenium-webdriver (2.12.1)
childprocess (>= 0.2.1)
- ffi (>= 1.0.7)
+ ffi (~> 1.0.9)
json_pure
rubyzip
- sinatra (1.2.6)
- rack (~> 1.1)
- tilt (< 2.0, >= 1.2.2)
+ sinatra (1.3.1)
+ rack (>= 1.3.4, ~> 1.3)
+ rack-protection (>= 1.1.2, ~> 1.1)
+ tilt (>= 1.3.3, ~> 1.3)
subexec (0.1.0)
tilt (1.3.3)
xpath (0.1.4)
@@ -56,7 +59,7 @@ PLATFORMS
ruby
DEPENDENCIES
- appraisal
+ appraisal (~> 0.4.0)
capybara (~> 1.0.0)
capybara-webkit!
mini_magick
View
31 gemfiles/1.1.gemfile.lock
@@ -1,13 +1,13 @@
PATH
- remote: /Users/jferris/Source/capybara-webkit
+ remote: /Users/gabe/thoughtbot/capybara-webkit
specs:
- capybara-webkit (0.6.1)
- capybara (< 1.2, >= 1.0.0)
+ capybara-webkit (0.7.2)
+ capybara (>= 1.0.0, < 1.2)
GEM
remote: http://rubygems.org/
specs:
- appraisal (0.3.8)
+ appraisal (0.4.0)
bundler
rake
capybara (1.1.1)
@@ -20,16 +20,18 @@ GEM
childprocess (0.2.2)
ffi (~> 1.0.6)
diff-lcs (1.1.3)
- ffi (1.0.9)
+ ffi (1.0.10)
json_pure (1.6.1)
- mime-types (1.16)
+ mime-types (1.17.2)
mini_magick (3.3)
subexec (~> 0.1.0)
nokogiri (1.5.0)
- rack (1.3.3)
+ rack (1.3.5)
+ rack-protection (1.1.4)
+ rack
rack-test (0.6.1)
rack (>= 1.0)
- rake (0.9.2)
+ rake (0.9.2.2)
rspec (2.6.0)
rspec-core (~> 2.6.0)
rspec-expectations (~> 2.6.0)
@@ -39,14 +41,15 @@ GEM
diff-lcs (~> 1.1.2)
rspec-mocks (2.6.0)
rubyzip (0.9.4)
- selenium-webdriver (2.7.0)
+ selenium-webdriver (2.12.1)
childprocess (>= 0.2.1)
- ffi (>= 1.0.7)
+ ffi (~> 1.0.9)
json_pure
rubyzip
- sinatra (1.2.6)
- rack (~> 1.1)
- tilt (< 2.0, >= 1.2.2)
+ sinatra (1.3.1)
+ rack (>= 1.3.4, ~> 1.3)
+ rack-protection (>= 1.1.2, ~> 1.1)
+ tilt (>= 1.3.3, ~> 1.3)
subexec (0.1.0)
tilt (1.3.3)
xpath (0.1.4)
@@ -56,7 +59,7 @@ PLATFORMS
ruby
DEPENDENCIES
- appraisal
+ appraisal (~> 0.4.0)
capybara (~> 1.1.0)
capybara-webkit!
mini_magick
View
1 lib/capybara/driver/webkit.rb
@@ -1,4 +1,5 @@
require "capybara"
+require "capybara/driver/webkit/version"
require "capybara/driver/webkit/node"
require "capybara/driver/webkit/browser"
require "capybara/driver/webkit/socket_debugger"
View
7 lib/capybara/driver/webkit/version.rb
@@ -0,0 +1,7 @@
+module Capybara
+ module Driver
+ class Webkit
+ VERSION = '0.7.2'.freeze
+ end
+ end
+end

0 comments on commit 6ba9dcb

Please sign in to comment.
Something went wrong with that request. Please try again.