Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Move development dependencies into the gemspec

  • Loading branch information...
commit 8ee2f5ce237063ccf548feb30bb7ec6cf001fd95 1 parent 36e13f7
@jferris jferris authored
Showing with 13 additions and 7 deletions.
  1. +1 −5 Gemfile
  2. +7 −1 Gemfile.lock
  3. +5 −1 capybara-webkit.gemspec
View
6 Gemfile
@@ -1,6 +1,2 @@
source "http://rubygems.org"
-gem "rspec", '~> 2.6.0', :require => false
-gem "capybara"
-gem "sinatra", :require => false
-gem "mini_magick", :require => false
-gem 'rake'
+gemspec
View
8 Gemfile.lock
@@ -1,3 +1,9 @@
+PATH
+ remote: .
+ specs:
+ capybara-webkit (0.6.1)
+ capybara (< 1.2, >= 1.0.0)
+
GEM
remote: http://rubygems.org/
specs:
@@ -47,7 +53,7 @@ PLATFORMS
ruby
DEPENDENCIES
- capybara
+ capybara-webkit!
mini_magick
rake
rspec (~> 2.6.0)
View
6 capybara-webkit.gemspec
@@ -13,7 +13,11 @@ Gem::Specification.new do |s|
s.require_path = "lib"
s.rubygems_version = "1.3.5"
s.summary = "Headless Webkit driver for Capybara"
- s.add_runtime_dependency "capybara", "~> 1.0.0"
+ s.add_runtime_dependency "capybara", [">= 1.0.0", "< 1.2"]
+ s.add_development_dependency "rspec", "~> 2.6.0"
+ s.add_development_dependency "sinatra"
+ s.add_development_dependency "mini_magick"
+ s.add_development_dependency "rake"
s.extensions = "extconf.rb"
end
Please sign in to comment.
Something went wrong with that request. Please try again.