Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Fail immediately when trying to compile with less than Qt 4.8

* We use features not present in Qt 4.7
* This fails earlier with a clearer message
  • Loading branch information...
commit f35e2df0df3b2e253d78ab96afa670662f862037 1 parent 525a8bb
@jferris jferris authored
Showing with 5 additions and 0 deletions.
  1. +5 −0 src/webkit_server.pro
View
5 src/webkit_server.pro
@@ -137,6 +137,11 @@ greaterThan(QT_MAJOR_VERSION, 4) {
} else {
QT += webkit
}
+lessThan(QT_MAJOR_VERSION, 5) {
+ lessThan(QT_MINOR_VERSION, 8) {
+ error(At least Qt 4.8.0 is required to run capybara-webkit.)
+ }
+}
CONFIG += console precompile_header
CONFIG -= app_bundle
PRECOMPILED_HEADER = stable.h
Please sign in to comment.
Something went wrong with that request. Please try again.