Skip to content
This repository
  • 3 commits
  • 3 files changed
  • 0 comments
  • 1 contributor

Showing 3 changed files with 17 additions and 2 deletions. Show diff stats Hide diff stats

  1. +15 0 NEWS.md
  2. +1 1  README.md
  3. +1 1  src/webkit_server.pro
15 NEWS.md
Source Rendered
... ... @@ -1,3 +1,18 @@
  1 +New for HEAD:
  2 +
  3 +* URL blacklist support.
  4 +* Various fixes for JavaScript console messages.
  5 +* Various compilation fixes.
  6 +* Fix status code and headers commands for iframes.
  7 +* Capybara 2.0 compatibility.
  8 +* Driver#render replaced by Session#save_screenshot.
  9 +* Driver#source and Driver#body return the HTML representation of the DOM. Unsupported content is returned as plain text.
  10 +* HTML5 multi-file upload support.
  11 +* Driver#url and Driver#requested_url removed.
  12 +* JavaScipt console messages and alerts are now written to the logger instead of directly to stdout.
  13 +* Dropped support for Qt 4.7.
  14 +* Fix deadlocks encountered during page load.
  15 +
1 16 New for 0.13.0:
2 17
3 18 * Better detect page load success, and better handle load failures.
2  README.md
Source Rendered
@@ -13,7 +13,7 @@ development toolkit. You'll need to download the Qt libraries to build and
13 13 install the gem. You can find instructions for downloading and installing QT on
14 14 the
15 15 [capybara-webkit wiki](https://github.com/thoughtbot/capybara-webkit/wiki/Installing-Qt-and-compiling-capybara-webkit).
16   -capybara-webkit requires Qt version 4.7 or higher. Qt 4.8 is recommended.
  16 +capybara-webkit requires Qt version 4.8.
17 17
18 18 Windows Support
19 19 ---------------
2  src/webkit_server.pro
@@ -33,7 +33,7 @@ HEADERS = \
33 33 NetworkCookieJar.h \
34 34 Header.h \
35 35 Render.h \
36   - body.h \
  36 + Body.h \
37 37 Status.h \
38 38 Headers.h \
39 39 UnsupportedContentHandler.h \

No commit comments for this range

Something went wrong with that request. Please try again.