Skip to content

WebkitInvalidResponseError, ruby 1.9.3, osx 10.7.3 #345

Closed
msp opened this Issue May 30, 2012 · 3 comments

3 participants

@msp
msp commented May 30, 2012

Hi there

I'm getting :

Unable to load URL: http://127.0.0.1:53808/activities/new (Capybara::Driver::Webkit::WebkitInvalidResponseError)
(eval): 2:in `has_css?'

on my @javascript tests (only)

Switching to the webkit_bug fails like so:

private method `puts' called for {:socket_class=>Capybara::Driver::Webkit::SocketDebugger}:Hash (NoMethodError)

https://gist.github.com/2836613

I can start webkit_server from within the bundle ok:

ruby-1.9.3-p0@kweekweek bigapplemac:bin matt$ ./webkit_server
Capybara-webkit server started, listening on port: 53929

Anything else I can try?

  • ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-darwin11.2.0]
  • capybara-1.1.2
  • capybara-webkit-0.12.0

Cheers

Matt

@jferris
thoughtbot, inc. member
jferris commented May 30, 2012

Sorry about that; 0.12.0 had a bug that was fixed by #344. I just pushed 0.12.1 with the fix.

Please try again with 0.12.1 and open a new issue with the debug output.

@jferris jferris closed this May 30, 2012
@msp
msp commented May 30, 2012

Thanks for the swift response Joe, will report back asap.

@kevinmtrowbridge

Hey -- I had this issue and 'bundle update capybara-webkit', updating to 0.12.1 -- fixed the issue. Thanks Joe, it worked.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.