Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Odd installation failure in 192 and 187 on Snow Leopard #6

Closed
drmanitoba opened this Issue · 9 comments

6 participants

@drmanitoba

Trying to install the gem, I downloaded/installed Qt, tried installing the gem on 1.9.2-p180 got this:

GET http://rubygems.org/latest_specs.4.8.gz
302 Found
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
GET http://gems.github.com/latest_specs.4.8.gz
200 OK
GET http://rubygems.org/specs.4.8.gz
302 Found
GET http://production.s3.rubygems.org/specs.4.8.gz
200 OK
GET http://gems.github.com/specs.4.8.gz
200 OK
Installing gem capybara-webkit-0.1.4
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/.gitignore
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/.rspec
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/.rvmrc
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/Gemfile
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/Gemfile.lock
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/LICENSE
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/README.md
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/Rakefile
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/capybara-webkit.gemspec
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/extconf.rb
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/lib/capybara-webkit.rb
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/lib/capybara/driver/webkit.rb
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/lib/capybara/driver/webkit/browser.rb
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/lib/capybara/driver/webkit/node.rb
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/spec/driver_spec.rb
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/spec/integration/driver_spec.rb
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/spec/integration/session_spec.rb
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/spec/spec_helper.rb
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/spec/support/socket_debugger.rb
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Command.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Command.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Connection.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Connection.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Evaluate.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Evaluate.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Execute.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Execute.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Find.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Find.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/JavascriptInvocation.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/JavascriptInvocation.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Node.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Node.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Reset.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Reset.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Server.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Server.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Source.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Source.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Url.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Url.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Visit.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/Visit.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/WebPage.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/WebPage.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/capybara.js
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/find_command.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/main.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/webkit_server.pro
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/src/webkit_server.qrc
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/templates/Command.cpp
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/templates/Command.h
/Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/webkit_server.pro
Building native extensions.  This could take a while...
ERROR:  Error installing capybara-webkit:
    ERROR: Failed to build gem native extension.

                /Users/drmanitoba/.rvm/rubies/ruby-1.9.2-p180/bin/ruby extconf.rb
/Users/drmanitoba/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems.rb:388:in `bin_path': can't find gem rake ([">= 0"]) with executable rake (Gem::GemNotFoundException)
    from /Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180/bin/rake:19:in `<main>'


Gem files will remain installed in /Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4 for inspection.
Results logged to /Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/./gem_make.out

Same thing happens with 1.8.7-p334

@jferris
Owner

I think this failed because you don't have the rake gem installed, but you have a rake executable on your PATH. I pushed a new version that specifies rake as a dependency. Can you try that out?

@drmanitoba

Yeah I saw that and double checked that I have rake installed. I do; probably should have mentioned that >_<

Either way, I tried the new version with the same results. Sorry I can't be more helpful, its the exact same output.

@drmanitoba drmanitoba closed this
@drmanitoba drmanitoba reopened this
@ngauthier

FYI I had this same error on 1.9.2, but not with REE 1.8.7.

@jonochang

Hi,

I had the same issue too. It appears that the path to the rake gems isn't being set properly. I forced it in the rake file mentioned. ie., /Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180/bin/rake

See below for an example from my rake file.

version = ">= 0"

ENV['GEM_HOME']=ENV['GEM_HOME'] || "~/.rvm/gems/ruby-1.9.2-p136"
ENV['GEM_PATH']=ENV['GEM_PATH'] || "~/.rvm/gems/ruby-1.9.2-p136@rails3:~/.rvm/gems/ruby-1.9.2-p136

if ARGV.first =~ /^(.*)$/ and Gem::Version.correct? $1 then
version = $1
ARGV.shift

@oriolgual

I'm having the same issue with rvm and 1.9.2

@jferris
Owner

This may be related to #10.

@oriolgual

Yes @jferris. it is related. I saw the issue but I understood root path as my root path, not capybara-webkit's.

In this issue context:

$ cd /Users/drmanitoba/.rvm/gems/ruby-1.9.2-p180@global/gems/capybara-webkit-0.1.4/
Here rvm will ask you to trust the gem rvmrc, say no, or if you have the automatic acceptance, just type rvm use 1.9.2
$ ruby extconf.rb

Solved.

@jferris
Owner

I removed the .rvmrc is 0.1.6.

@jferris jferris closed this
@Weareartificial

I was having this same issue and found that reinstalling QT fixed it (from github capybara-webkit doc):

apt-get install libqt4-dev

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.