changing README to alert users about OS X 10.7 binary incompatibility. #117

Merged
merged 3 commits into from Aug 4, 2011

Projects

None yet

6 participants

@plentz
Contributor
plentz commented Jul 27, 2011

No description provided.

@nazgob
Contributor
nazgob commented Jul 27, 2011

+1, i had to do that too

@cgriego
Contributor
cgriego commented Jul 27, 2011

Homebrew is now using its own precompiled binary for qt so it doesn't take a long time to install anymore.

@plentz
Contributor
plentz commented Jul 27, 2011

@cgriego the point is that you need to install from source to make it work in Lion(the patch/fix is applied only when installing from source).

@plentz
Contributor
plentz commented Jul 27, 2011

I just edited the README adding the command you'll need to build from source using homebrew, to make it cleaner.

@cgriego
Contributor
cgriego commented Jul 28, 2011

I installed from homebrew on Lion without building from source and it works for me…

@plentz
Contributor
plentz commented Jul 28, 2011

@cgriego you installed it before Lion or after Lion? the problem is when you try to install it after Lion is installed.

related:
http://stackoverflow.com/questions/6794005/qt-4-8-beta-and-mac-osx-lion-phonon-error

@cgriego
Contributor
cgriego commented Jul 29, 2011

I installed in on a new laptop with a factory install of Lion.

@plentz
Contributor
plentz commented Jul 29, 2011

weird! anyone can confirm this?

@gabebw gabebw and 1 other commented on an outdated diff Aug 4, 2011
README.md
@@ -10,7 +10,9 @@ capybara-webkit depends on a WebKit implementation from Qt, a cross-platform dev
OS X:
-[Download the non-debug Cocoa package](http://qt.nokia.com/downloads/qt-for-open-source-cpp-development-on-mac-os-x). Note that installing Qt via homebrew takes more than an hour, so we don't recommend it.
+[Download the non-debug Cocoa package](http://qt.nokia.com/downloads/qt-for-open-source-cpp-development-on-mac-os-x). Note that these binaries aren't compatible with OS X 10.7(Lion), so you'll need to install Qt via homebrew(can take more than an hour). To build from source:
@gabebw
gabebw Aug 4, 2011 Member

Can you split this into a new "OS X Lion (10.7)" section, and just change the header on the current one from "OS X" to "OS X < 10.7"? The Lion instructions are kind of buried here.

@plentz
plentz Aug 4, 2011 Contributor

done

@gabebw gabebw merged commit 612028d into thoughtbot:master Aug 4, 2011
@NickClark

@plentz, Im with @cgriego on this. Webkit is working fine using precompiled version. I got my machine running the day lion was released. I did a clean Lion install, not an upgrade.

@tristandunn
Contributor

The "bottle" install via Homebrew worked fine for me on a clean install of Lion as well.

@turadg turadg added a commit to turadg/capybara-webkit that referenced this pull request Sep 14, 2011
@turadg turadg Homebrew's `qt` binary bottle works for many people in Lion
(confirmatory reports on #117)
e912484
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment