Skip to content
Newer
Older
100644 40 lines (35 sloc) 1.58 KB
29128a8 @gabebw Bump gem versions and clean up gemspec
gabebw authored Apr 8, 2012
1 $LOAD_PATH.push File.expand_path('../lib', __FILE__)
0453b57 @mjankowski Add version constant to match common style
mjankowski authored Apr 6, 2012
2 require 'clearance/version'
2aa3cd8 @croaky Bump to 0.10.1
croaky authored Feb 9, 2011
3 require 'date'
4
9a477b2 @mike-burns Add gemspec back
mike-burns authored Jun 29, 2010
5 Gem::Specification.new do |s|
32dc600 @mike-burns Re-arrange the gemspec to be in a more canonical order
mike-burns authored Jul 23, 2012
6 s.name = %q{clearance}
7 s.version = Clearance::VERSION
8 s.authors = [
9 'Dan Croak', 'Mike Burns', 'Jason Morrison', 'Joe Ferris', 'Eugene Bolshakov',
10 'Nick Quaranto', 'Josh Nichols', 'Mike Breen', 'Jon Yurek', 'Chad Pytel'
11 ]
12 s.email = %q{support@thoughtbot.com}
13 s.homepage = %q{http://github.com/thoughtbot/clearance}
14 s.summary = %q{Rails authentication & authorization with email & password.}
15 s.description = %q{Rails authentication & authorization with email & password.}
16
26860a1 @mike-burns Bump to 1.0.0.rc1
mike-burns authored Jul 23, 2012
17 s.files = `git ls-files`.split("\n")
18 s.test_files = `git ls-files -- {features,spec}/*`.split("\n")
32dc600 @mike-burns Re-arrange the gemspec to be in a more canonical order
mike-burns authored Jul 23, 2012
19 s.extra_rdoc_files = %w(LICENSE README.md)
20 s.rdoc_options = ['--charset=UTF-8']
21 s.require_paths = ['lib']
22
96fdd7a @mike-burns Require Ruby 1.9.2 or anything greater
mike-burns authored Jul 23, 2012
23 s.required_ruby_version = Gem::Requirement.new('>= 1.9.2')
24
2900d73 @croaky Upgrade dependencies
croaky authored Jul 22, 2012
25 s.add_dependency 'bcrypt-ruby'
26 s.add_dependency 'rails', '>= 3.0'
27 s.add_development_dependency 'appraisal', '0.4.1'
28 s.add_development_dependency 'aruba', '0.4.11'
29 s.add_development_dependency 'bourne', '1.1.2'
ec13c73 @croaky Test against latest Rails dependencies
croaky authored Sep 19, 2012
30 s.add_development_dependency 'bundler', '~> 1.2.0'
2900d73 @croaky Upgrade dependencies
croaky authored Jul 22, 2012
31 s.add_development_dependency 'capybara', '1.1.2'
32 s.add_development_dependency 'cucumber-rails', '1.1.1'
33 s.add_development_dependency 'database_cleaner', '0.8.0'
34 s.add_development_dependency 'factory_girl_rails', '3.5.0'
35 s.add_development_dependency 'rspec-rails', '2.11.0'
36 s.add_development_dependency 'shoulda-matchers', '1.2.0'
37 s.add_development_dependency 'sqlite3', '1.3.6'
38 s.add_development_dependency 'timecop', '0.3.5'
9a477b2 @mike-burns Add gemspec back
mike-burns authored Jun 29, 2010
39 end
Something went wrong with that request. Please try again.