Skip to content
Newer
Older
100644 31 lines (26 sloc) 673 Bytes
761faec @derekprior Test & Support Ruby 2.2 across Rails versions
derekprior authored
1 if RUBY_VERSION < "2.2.0"
6dda20c @derekprior Start testing against Rails 5 beta 1
derekprior authored
2 appraise 'rails32' do
761faec @derekprior Test & Support Ruby 2.2 across Rails versions
derekprior authored
3 gem 'rails', '~> 3.2.21'
4 end
9238a6a @derekprior Add Ruby 2.1 and Rails 4.1 to test matrix
derekprior authored
5 end
6
6dda20c @derekprior Start testing against Rails 5 beta 1
derekprior authored
7 appraise 'rails40' do
761faec @derekprior Test & Support Ruby 2.2 across Rails versions
derekprior authored
8 gem 'rails', '~> 4.0.13'
9 gem 'test-unit'
9238a6a @derekprior Add Ruby 2.1 and Rails 4.1 to test matrix
derekprior authored
10 end
357118c @derekprior Add Ruby 2.0 to tests/travis
derekprior authored
11
6dda20c @derekprior Start testing against Rails 5 beta 1
derekprior authored
12 appraise 'rails41' do
761faec @derekprior Test & Support Ruby 2.2 across Rails versions
derekprior authored
13 gem 'rails', '~> 4.1.9'
c3643fe @derekprior Support Rails 4.2
derekprior authored
14 end
15
6dda20c @derekprior Start testing against Rails 5 beta 1
derekprior authored
16 appraise 'rails42' do
c3643fe @derekprior Support Rails 4.2
derekprior authored
17 gem 'rails', '~> 4.2.0'
08e24fc @sikachu Add Appraisal configuration file
sikachu authored
18 end
6dda20c @derekprior Start testing against Rails 5 beta 1
derekprior authored
19
20 if RUBY_VERSION >= "2.2.0"
21 appraise "rails50" do
22 gem "rails", "~> 5.0.0.beta1"
23 gem "rspec-rails", github: "rspec/rspec-rails"
24 gem "rspec-support", github: "rspec/rspec-support"
25 gem "rspec-core", github: "rspec/rspec-core"
26 gem "rspec-mocks", github: "rspec/rspec-mocks"
27 gem "rspec-expectations", github: "rspec/rspec-expectations"
28 gem "rspec", github: "rspec/rspec"
29 end
30 end
Something went wrong with that request. Please try again.