Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

[#180] Use Travis CI

* Start by supporting Ruby 1.8.7, REE, 1.9.2, 1.93.
* Use Appraisal to support Rails 3.0 and 3.1.
  • Loading branch information...
commit 91674c675f50bd84c2314827c6fd85d2f0f92b07 1 parent 3ecb5e5
@croaky croaky authored
View
14 .travis.yml
@@ -0,0 +1,14 @@
+rvm:
+ - ree-1.8.7
+ - 1.8.7
+ - 1.9.2
+ - 1.9.3
+before_install:
+ - gem update --system
+script: "bundle exec rake"
+gemfile:
+ - gemfiles/3.0.9.gemfile
+ - gemfiles/3.1.0.gemfile
+branches:
+ only:
+ - master
View
2  README.md
@@ -1,4 +1,4 @@
-Clearance
+Clearance [![Build Status](https://secure.travis-ci.org/thoughtbot/clearance.png)](http://travis-ci.org/thoughtbot/clearance?branch=master)
=========
Rails authentication & authorization with email & password.
View
8 gemfiles/3.0.9.gemfile
@@ -2,12 +2,12 @@
source "http://rubygems.org"
-gem "rails", "3.0.9"
-gem "shoulda-matchers", :git=>"git://github.com/thoughtbot/shoulda-matchers.git"
-gem "database_cleaner"
-gem "aruba", "~> 0.4.2"
gem "capybara", "~> 1.1.1"
gem "factory_girl_rails"
+gem "shoulda-matchers", :git=>"git://github.com/thoughtbot/shoulda-matchers.git"
+gem "database_cleaner"
gem "launchy"
+gem "aruba", "~> 0.4.2"
+gem "rails", "3.0.9"
gemspec :path=>"../"
View
2  gemfiles/3.0.9.gemfile.lock
@@ -5,7 +5,7 @@ GIT
shoulda-matchers (1.0.0)
PATH
- remote: /home/mike/lib/clearance
+ remote: /Users/croaky/dev/clearance
specs:
clearance (0.15.0)
diesel (~> 0.1.5)
View
8 gemfiles/3.1.0.gemfile
@@ -2,12 +2,12 @@
source "http://rubygems.org"
-gem "rails", "3.1.0"
-gem "shoulda-matchers", :git=>"git://github.com/thoughtbot/shoulda-matchers.git"
-gem "database_cleaner"
-gem "aruba", "~> 0.4.2"
gem "capybara", "~> 1.1.1"
gem "factory_girl_rails"
+gem "shoulda-matchers", :git=>"git://github.com/thoughtbot/shoulda-matchers.git"
+gem "database_cleaner"
gem "launchy"
+gem "aruba", "~> 0.4.2"
+gem "rails", "3.1.0"
gemspec :path=>"../"
View
2  gemfiles/3.1.0.gemfile.lock
@@ -5,7 +5,7 @@ GIT
shoulda-matchers (1.0.0)
PATH
- remote: /home/mike/lib/clearance
+ remote: /Users/croaky/dev/clearance
specs:
clearance (0.15.0)
diesel (~> 0.1.5)
Please sign in to comment.
Something went wrong with that request. Please try again.