Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

use newer diesel, appraisal. features/support/appraisal.rb no longer …

…necessary.
  • Loading branch information...
commit ef953281fb930fcadd4f56834021edd7ac469fda 1 parent 316db9b
@croaky croaky authored
View
3  Gemfile
@@ -1,10 +1,9 @@
source "http://rubygems.org"
+gemspec
gem "rails", "3.0.9"
gem "sqlite3"
-gem "diesel", :git => "git://github.com/thoughtbot/diesel.git"
-
gem "cucumber-rails", '1.0.0'
gem "capybara", "1.0.0"
gem "factory_girl_rails"
View
23 Gemfile.lock
@@ -1,25 +1,25 @@
GIT
remote: git://github.com/thoughtbot/appraisal.git
- revision: f8029181543b4bc4bdea03735a3b1e558fd66501
+ revision: 549f3fac473572741708bd058cd78c9212b2391b
specs:
- appraisal (0.3.5)
+ appraisal (0.3.6)
aruba (~> 0.4.2)
bundler
rake
GIT
- remote: git://github.com/thoughtbot/diesel.git
- revision: f68a990573e2684bb4645a90876603de0a772b69
- specs:
- diesel (0.1.4)
- railties
-
-GIT
remote: git://github.com/thoughtbot/shoulda-matchers.git
revision: a922b8ec38b65ae3274f194e90eaff6ac642d0b1
specs:
shoulda-matchers (1.0.0.beta3)
+PATH
+ remote: .
+ specs:
+ clearance (0.12.0)
+ diesel (~> 0.1.5)
+ rails (>= 3.0)
+
GEM
remote: http://rubygems.org/
specs:
@@ -82,6 +82,8 @@ GEM
nokogiri (>= 1.4.4)
rack-test (>= 0.5.7)
database_cleaner (0.6.7)
+ diesel (0.1.5)
+ railties
diff-lcs (1.1.2)
erubis (2.6.6)
abstract (>= 1.0.0)
@@ -163,10 +165,11 @@ PLATFORMS
DEPENDENCIES
appraisal!
aruba (~> 0.4.2)
+ bundler (~> 1.0.0)
capybara (= 1.0.0)
+ clearance!
cucumber-rails (= 1.0.0)
database_cleaner
- diesel!
factory_girl_rails
launchy
mocha
View
2  clearance.gemspec
@@ -23,7 +23,7 @@ Gem::Specification.new do |s|
s.rubygems_version = %q{1.3.7}
s.add_dependency('rails', '>= 3.0')
- s.add_dependency('diesel', '~> 0.1.4')
+ s.add_dependency('diesel', '~> 0.1.5')
s.add_development_dependency('bundler', '~> 1.0.0')
View
1  features/integration.feature
@@ -14,7 +14,6 @@ Feature: integrate with application
And I add the "database_cleaner" gem
And I add the "clearance" gem from this project
And I add the "diesel" gem from git "git://github.com/thoughtbot/diesel.git"
- And I reset Bundler environment variable
And I run `bundle install --local`
And I successfully run `bundle exec rails generate cucumber:install`
And I disable Capybara Javascript emulation
View
18 features/support/appraisal.rb
@@ -1,18 +0,0 @@
-BUNDLE_ENV_VARS = %w(RUBYOPT BUNDLE_PATH BUNDLE_BIN_PATH BUNDLE_GEMFILE)
-ORIGINAL_BUNDLE_VARS = Hash[ENV.select{ |key,value| BUNDLE_ENV_VARS.include?(key) }]
-
-Before do
- ENV['BUNDLE_GEMFILE'] = File.join(Dir.pwd, ENV['BUNDLE_GEMFILE'])
-end
-
-After do
- ORIGINAL_BUNDLE_VARS.each_pair do |key, value|
- ENV[key] = value
- end
-end
-
-When /^I reset Bundler environment variable$/ do
- BUNDLE_ENV_VARS.each do |key|
- ENV[key] = nil
- end
-end
View
2  gemfiles/3.0.9.gemfile
@@ -5,7 +5,6 @@ source "http://rubygems.org"
gem "sqlite3"
gem "rails", "3.0.9"
gem "shoulda-matchers", :git=>"git://github.com/thoughtbot/shoulda-matchers.git"
-gem "diesel", :git=>"git://github.com/thoughtbot/diesel.git"
gem "database_cleaner"
gem "rspec-rails", "~> 2.6.0"
gem "aruba", "~> 0.4.2"
@@ -16,3 +15,4 @@ gem "capybara", "1.0.0"
gem "factory_girl_rails"
gem "launchy"
+gemspec :path=>"../"
View
23 gemfiles/3.0.9.gemfile.lock
@@ -1,25 +1,25 @@
GIT
remote: git://github.com/thoughtbot/appraisal.git
- revision: f8029181543b4bc4bdea03735a3b1e558fd66501
+ revision: 549f3fac473572741708bd058cd78c9212b2391b
specs:
- appraisal (0.3.5)
+ appraisal (0.3.6)
aruba (~> 0.4.2)
bundler
rake
GIT
- remote: git://github.com/thoughtbot/diesel.git
- revision: 9a7955eadd3e2f445ecf3d2d58edfc2a5e80a20b
- specs:
- diesel (0.1.4)
- railties
-
-GIT
remote: git://github.com/thoughtbot/shoulda-matchers.git
revision: 85d3e5ea000cf162ef672059ea5e5f77f3ca9f03
specs:
shoulda-matchers (1.0.0.beta3)
+PATH
+ remote: /Users/lawless/dev/clearance
+ specs:
+ clearance (0.12.0)
+ diesel (~> 0.1.5)
+ rails (>= 3.0)
+
GEM
remote: http://rubygems.org/
specs:
@@ -82,6 +82,8 @@ GEM
nokogiri (>= 1.4.4)
rack-test (>= 0.5.7)
database_cleaner (0.6.7)
+ diesel (0.1.5)
+ railties
diff-lcs (1.1.2)
erubis (2.6.6)
abstract (>= 1.0.0)
@@ -163,10 +165,11 @@ PLATFORMS
DEPENDENCIES
appraisal!
aruba (~> 0.4.2)
+ bundler (~> 1.0.0)
capybara (= 1.0.0)
+ clearance!
cucumber-rails (= 1.0.0)
database_cleaner
- diesel!
factory_girl_rails
launchy
mocha
View
2  gemfiles/3.1.0.rc4.gemfile
@@ -9,7 +9,6 @@ gem "rails", "3.1.0.rc4"
gem "sass-rails"
gem "shoulda-matchers", :git=>"git://github.com/thoughtbot/shoulda-matchers.git"
gem "coffee-script"
-gem "diesel", :git=>"git://github.com/thoughtbot/diesel.git"
gem "database_cleaner"
gem "rspec-rails", "~> 2.6.0"
gem "aruba", "~> 0.4.2"
@@ -21,3 +20,4 @@ gem "capybara", "1.0.0"
gem "factory_girl_rails"
gem "launchy"
+gemspec :path=>"../"
View
23 gemfiles/3.1.0.rc4.gemfile.lock
@@ -1,25 +1,25 @@
GIT
remote: git://github.com/thoughtbot/appraisal.git
- revision: f8029181543b4bc4bdea03735a3b1e558fd66501
+ revision: 549f3fac473572741708bd058cd78c9212b2391b
specs:
- appraisal (0.3.5)
+ appraisal (0.3.6)
aruba (~> 0.4.2)
bundler
rake
GIT
- remote: git://github.com/thoughtbot/diesel.git
- revision: 9a7955eadd3e2f445ecf3d2d58edfc2a5e80a20b
- specs:
- diesel (0.1.4)
- railties
-
-GIT
remote: git://github.com/thoughtbot/shoulda-matchers.git
revision: 85d3e5ea000cf162ef672059ea5e5f77f3ca9f03
specs:
shoulda-matchers (1.0.0.beta3)
+PATH
+ remote: /Users/lawless/dev/clearance
+ specs:
+ clearance (0.12.0)
+ diesel (~> 0.1.5)
+ rails (>= 3.0)
+
GEM
remote: http://rubygems.org/
specs:
@@ -91,6 +91,8 @@ GEM
nokogiri (>= 1.4.4)
rack-test (>= 0.5.7)
database_cleaner (0.6.7)
+ diesel (0.1.5)
+ railties
diff-lcs (1.1.2)
erubis (2.7.0)
execjs (1.1.3)
@@ -198,11 +200,12 @@ PLATFORMS
DEPENDENCIES
appraisal!
aruba (~> 0.4.2)
+ bundler (~> 1.0.0)
capybara (= 1.0.0)
+ clearance!
coffee-script
cucumber-rails (= 1.0.0)
database_cleaner
- diesel!
factory_girl_rails
jquery-rails
launchy
Please sign in to comment.
Something went wrong with that request. Please try again.