Skip to content
This repository

Oct 16, 2012

  1. Gabe Berke-Williams

    Grammar

    gabebw authored
  2. Harlow Ward

    Generators for RSpec integration suite

    + Feature to check migrations after clearance:install
    + Create generator for intalling rspec specs
    + Updated readme for RSpec integration generator
    harlow authored

Oct 15, 2012

  1. Gabe Berke-Williams

    Link to Airbrake.io.

    Airbrakeapp.com gives an SSL warning.
    gabebw authored

Oct 12, 2012

  1. Gabe Berke-Williams

    Don't market Clearance as an authorization library

    gabebw authored

Sep 20, 2012

  1. Dan Croak

    Encourage developers to use 1.0.0.rc2

    croaky authored
  2. Dan Croak

    Encourage developers to try 1.0.0.rc2

    croaky authored
  3. Dan Croak

    Clean up Github links in README

    croaky authored

Sep 14, 2012

  1. Dan Croak

    Improve README

    * Generalize versions of Rails/Ruby we test against.
    * Add `bundle` line.
    * Order main API walkthrough by importance and group authorization.
    * Use Ruby 1.9 hash syntax.
    * Get closer to 80 character limit on lines with links.
    * Use Ruby . or # syntax to evoke class or instance method.
    * Add Code Climate badge.
    croaky authored

Jul 23, 2012

  1. Dan Croak

    Correct NEWS and README

    * You can use Clearance after you've created a Rails app or users
      table. If you have users already, you'll need to edit the default
      migration that Clearance generates.
    * We are testing against latest Rails 3.0.x, 3.1.x, and 3.2.x.
    croaky authored
  2. Gabe Berke-Williams

    Link to the real contribution guidelines.

    gabebw authored
  3. Mike Burns

    Require Ruby 1.9.2 or anything greater

    mike-burns authored

Jul 22, 2012

  1. Dan Croak

    Upgrade dependencies

    * Support Rails 3.0.15, 3.1.6, 3.2.6.
    * Apply style guidelines to test suite.
    * Be more strict about development dependencies.
    croaky authored
  2. Dan Croak

    Overhaul README.md

    Intention is to better communicate the API.
    croaky authored

Jul 19, 2012

  1. Mike Burns

    Remove the salt from the DB migration

    The salt column is only needed for SHA1 and MD5 strategies, which  are
    not the default. The README contains instructions for adding the salt
    back before switching to those strategies.
    mike-burns authored

Jun 29, 2012

  1. BCrypt for passwords

    This commit makes BCrypt the default for new setups, and introduces a
    strategy for converting existing infrastructure to BCrypt.
    
    To switch to BCrypt now:
    
        Clearance.configure do |config|
          config.password_strategy = Clearance::PasswordStrategies::BCrypt
        end
    
    To set the password strategy to the conversion layer:
    
        Clearance.configure do |config|
          config.password_strategy = Clearance::PasswordStrategies::BCryptMigrationFromSHA1
        end
    
    To continue to use SHA1:
    
        Clearance.configure do |config|
          config.password_strategy = Clearance::PasswordStrategies::SHA1
        end
    Dan Croak and Gabe Berke-Williams authored mike-burns committed
  2. Provide router constraints

    Adds SignedInConstraint and SignedOutConstraint, useful from the Rails
    router. For example, to redirect admins to their admin dashboard as the
    home page:
    
        constraints(SignedInConstraint.new {|user| user.admin?}) do
          root :to => 'admins/dashboard#index'
        end
    Arun Agrawal and Gabe Berke-Williams authored mike-burns committed

Jun 18, 2012

  1. Gabe Berke-Williams

    List the correct Rails versions in the README.

    gabebw authored

Apr 04, 2012

  1. Matt Jankowski

    update README to reflect current tested rails versions

    mjankowski authored

Mar 16, 2012

  1. Mike Burns

    Bump to 0.16.0.

    mike-burns authored

Feb 27, 2012

  1. Added blowfish password encryption strategy.

    squarism authored

Feb 17, 2012

  1. Dan Croak

    [#180] Use Travis CI

    * Start by supporting Ruby 1.8.7, REE, 1.9.2, 1.93.
    * Use Appraisal to support Rails 3.0 and 3.1.
    croaky authored

Dec 01, 2011

  1. Joe Ferris

    Perform authentication in Rack middleware

    jferris authored

Nov 21, 2011

  1. Gabe Berke-Williams

    We actually test against 3.1.0 proper.

    gabebw authored

Oct 14, 2011

  1. Neil Parikh

    Updated link on README.

    neilparikh authored

Oct 10, 2011

  1. Dan Croak

    improving the README's documentation. all overrides should now be doc…

    …umented clearly, with links to the engine's codebase for further exploration.
    croaky authored
  2. Gabe Berke-Williams

    typo

    gabebw authored
  3. Dan Croak

    explicitly list out dependencies of Cucumber steps

    croaky authored

Jul 29, 2011

  1. Escape underscore in "Overriding defaults" section

    Quico Moya authored

Jul 22, 2011

  1. Mike Burns

    Add a document describing how to contribute.

    mike-burns authored

Jul 05, 2011

  1. Dan Croak

    more details in the README

    croaky authored

Jul 01, 2011

  1. Dan Croak

    better instructions for Cucumber installations

    croaky authored

Jun 30, 2011

  1. Dan Croak

    mimic diesel's naming for clearance/testing. mimic shoulda-matcher's …

    …handling of test/unit v. minitest
    croaky authored
  2. Dan Croak

    legit deny_access matcher

    croaky authored

Jun 29, 2011

  1. Dan Croak

    passing features with test_matchers required in RSpec suites

    croaky authored

Jun 05, 2011

  1. Dan Croak

    clarifications to the README based on feedback

    croaky authored
Something went wrong with that request. Please try again.