Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Change the dependencies to be defined in Gemspec instead.

  • Loading branch information...
commit f8de68cbe8c41ba33101f82b88ffa01090b77fda 1 parent a82e6f0
@sikachu sikachu authored
Showing with 88 additions and 74 deletions.
  1. +2 −8 Gemfile
  2. +79 −65 Gemfile.lock
  3. +7 −1 diesel.gemspec
View
10 Gemfile
@@ -1,9 +1,3 @@
source "http://rubygems.org"
-gem "cucumber"
-gem "aruba"
-gem "rake"
-gem "rspec-rails", :require => false
-gem "rails", ">= 3.0.3", :require => false
-gem "thin"
-gem "sqlite3-ruby", :require => false
-
+gemspec
+gem "rails", ">= 3.0"
View
144 Gemfile.lock
@@ -1,113 +1,127 @@
+PATH
+ remote: .
+ specs:
+ diesel (0.1.4)
+ railties
+
GEM
remote: http://rubygems.org/
specs:
abstract (1.0.0)
- actionmailer (3.0.3)
- actionpack (= 3.0.3)
- mail (~> 2.2.9)
- actionpack (3.0.3)
- activemodel (= 3.0.3)
- activesupport (= 3.0.3)
+ actionmailer (3.0.7)
+ actionpack (= 3.0.7)
+ mail (~> 2.2.15)
+ actionpack (3.0.7)
+ activemodel (= 3.0.7)
+ activesupport (= 3.0.7)
builder (~> 2.1.2)
erubis (~> 2.6.6)
- i18n (~> 0.4)
+ i18n (~> 0.5.0)
rack (~> 1.2.1)
- rack-mount (~> 0.6.13)
- rack-test (~> 0.5.6)
+ rack-mount (~> 0.6.14)
+ rack-test (~> 0.5.7)
tzinfo (~> 0.3.23)
- activemodel (3.0.3)
- activesupport (= 3.0.3)
+ activemodel (3.0.7)
+ activesupport (= 3.0.7)
builder (~> 2.1.2)
- i18n (~> 0.4)
- activerecord (3.0.3)
- activemodel (= 3.0.3)
- activesupport (= 3.0.3)
+ i18n (~> 0.5.0)
+ activerecord (3.0.7)
+ activemodel (= 3.0.7)
+ activesupport (= 3.0.7)
arel (~> 2.0.2)
tzinfo (~> 0.3.23)
- activeresource (3.0.3)
- activemodel (= 3.0.3)
- activesupport (= 3.0.3)
- activesupport (3.0.3)
- arel (2.0.6)
- aruba (0.2.7)
- background_process
- cucumber (~> 0.10.0)
- background_process (1.2)
+ activeresource (3.0.7)
+ activemodel (= 3.0.7)
+ activesupport (= 3.0.7)
+ activesupport (3.0.7)
+ appraisal (0.3.5)
+ aruba (~> 0.3.6)
+ bundler
+ rake
+ arel (2.0.10)
+ aruba (0.3.6)
+ childprocess (>= 0.1.7)
+ cucumber (>= 0.10.0)
+ rspec (>= 2.5.0)
builder (2.1.2)
- cucumber (0.10.0)
+ childprocess (0.1.9)
+ ffi (~> 1.0.6)
+ cucumber (0.10.5)
builder (>= 2.1.2)
- diff-lcs (~> 1.1.2)
- gherkin (~> 2.3.2)
- json (~> 1.4.6)
- term-ansicolor (~> 1.0.5)
- daemons (1.1.0)
+ diff-lcs (>= 1.1.2)
+ gherkin (~> 2.4.0)
+ json (>= 1.4.6)
+ term-ansicolor (>= 1.0.5)
+ daemons (1.1.3)
diff-lcs (1.1.2)
erubis (2.6.6)
abstract (>= 1.0.0)
eventmachine (0.12.10)
- gherkin (2.3.2)
- json (~> 1.4.6)
- term-ansicolor (~> 1.0.5)
+ ffi (1.0.9)
+ gherkin (2.4.0)
+ json (>= 1.4.6)
i18n (0.5.0)
- json (1.4.6)
- mail (2.2.12)
+ json (1.5.1)
+ mail (2.2.19)
activesupport (>= 2.3.6)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.16)
polyglot (0.3.1)
- rack (1.2.1)
- rack-mount (0.6.13)
+ rack (1.2.3)
+ rack-mount (0.6.14)
rack (>= 1.0.0)
- rack-test (0.5.6)
+ rack-test (0.5.7)
rack (>= 1.0)
- rails (3.0.3)
- actionmailer (= 3.0.3)
- actionpack (= 3.0.3)
- activerecord (= 3.0.3)
- activeresource (= 3.0.3)
- activesupport (= 3.0.3)
+ rails (3.0.7)
+ actionmailer (= 3.0.7)
+ actionpack (= 3.0.7)
+ activerecord (= 3.0.7)
+ activeresource (= 3.0.7)
+ activesupport (= 3.0.7)
bundler (~> 1.0)
- railties (= 3.0.3)
- railties (3.0.3)
- actionpack (= 3.0.3)
- activesupport (= 3.0.3)
+ railties (= 3.0.7)
+ railties (3.0.7)
+ actionpack (= 3.0.7)
+ activesupport (= 3.0.7)
rake (>= 0.8.7)
thor (~> 0.14.4)
- rake (0.8.7)
- rspec (2.3.0)
- rspec-core (~> 2.3.0)
- rspec-expectations (~> 2.3.0)
- rspec-mocks (~> 2.3.0)
- rspec-core (2.3.1)
- rspec-expectations (2.3.0)
+ rake (0.9.2)
+ rspec (2.6.0)
+ rspec-core (~> 2.6.0)
+ rspec-expectations (~> 2.6.0)
+ rspec-mocks (~> 2.6.0)
+ rspec-core (2.6.4)
+ rspec-expectations (2.6.0)
diff-lcs (~> 1.1.2)
- rspec-mocks (2.3.0)
- rspec-rails (2.3.1)
+ rspec-mocks (2.6.0)
+ rspec-rails (2.6.1)
actionpack (~> 3.0)
activesupport (~> 3.0)
railties (~> 3.0)
- rspec (~> 2.3.0)
- sqlite3-ruby (1.3.2)
+ rspec (~> 2.6.0)
+ sqlite3 (1.3.3)
+ sqlite3-ruby (1.3.3)
+ sqlite3 (>= 1.3.3)
term-ansicolor (1.0.5)
- thin (1.2.7)
+ thin (1.2.11)
daemons (>= 1.0.9)
eventmachine (>= 0.12.6)
rack (>= 1.0.0)
thor (0.14.6)
treetop (1.4.9)
polyglot (>= 0.3.1)
- tzinfo (0.3.23)
+ tzinfo (0.3.27)
PLATFORMS
ruby
DEPENDENCIES
- aruba
+ appraisal
cucumber
- rails (>= 3.0.3)
- rake
- rspec-rails
+ diesel!
+ rails (>= 3.0)
+ rspec-rails (~> 2.6.1)
sqlite3-ruby
thin
View
8 diesel.gemspec
@@ -24,7 +24,13 @@ Gem::Specification.new do |s|
s.email = %q{support@thoughtbot.com}
s.homepage = "http://github.com/thoughtbot/diesel"
- s.add_dependency('railties', '~> 3.0.3')
+ s.add_dependency('railties')
+
+ s.add_development_dependency('cucumber')
+ s.add_development_dependency('appraisal')
+ s.add_development_dependency('rspec-rails', '~> 2.6.1')
+ s.add_development_dependency('thin')
+ s.add_development_dependency('sqlite3-ruby')
s.platform = Gem::Platform::RUBY
s.rubygems_version = %q{1.2.0}
Please sign in to comment.
Something went wrong with that request. Please try again.