Skip to content
Commits on Feb 12, 2014
  1. @joshuaclayton
  2. @joshuaclayton

    Support Spring out of the box

    joshuaclayton committed
    Closes #120
Commits on Feb 11, 2014
  1. @joshuaclayton

    Bump version to 4.4.0

    joshuaclayton committed
  2. @joshuaclayton
Commits on Jan 13, 2014
  1. @Agsiegert @joshuaclayton

    small typo correction line 35

    Agsiegert committed with joshuaclayton
    line 35
    If you want disable this feature,
    
    changed to:
    If you want to disable this feature,
Commits on Dec 16, 2013
  1. @joshuaclayton
Commits on Nov 4, 2013
  1. @joshuaclayton

    Bump version to 4.3.0

    joshuaclayton committed
  2. @joshuaclayton
  3. @joshuaclayton
  4. @joshuaclayton
Commits on Apr 5, 2013
  1. @joshuaclayton
  2. @Iazel @joshuaclayton

    Update README.md

    Iazel committed with joshuaclayton
    Add how-to disable factories generator and how-to change default directory.
    `:suffix` option is moved to `generators.factory_girl`
    
    Closes #92
  3. @joshuaclayton

    Break generator up for separate frameworks

    joshuaclayton committed
    Closes #91, Closes #62
Commits on Feb 28, 2013
  1. @vfrride

    Uses secure RubyGems URL

    vfrride committed
Commits on Feb 15, 2013
  1. @jordimassaguerpla @joshuaclayton

    add license information to gemspec

    jordimassaguerpla committed with joshuaclayton
    This way you can use the rubygems.org API to get this information
Commits on Feb 8, 2013
  1. @joshuaclayton
  2. @joshuaclayton

    Bump version to 4.2.1

    joshuaclayton committed
  3. @joshuaclayton

    Require factory_girl_rails explicitly in generator

    joshuaclayton committed
    This resolves an issue where factory_girl_rails won't get required if
    you only have factory_girl_rails declared in the :test group of a Rails
    app.
    
    Closes #89
  4. @joshuaclayton

    Remove debugging

    joshuaclayton committed
Commits on Feb 5, 2013
  1. @joshuaclayton
Commits on Jan 29, 2013
  1. @mjankowski
Commits on Jan 25, 2013
  1. @joshuaclayton

    Bump version to 4.2.0

    joshuaclayton committed
  2. @joshuaclayton

    WIP: Upgrade to 4.2.0

    joshuaclayton committed
    Currently one failure surrounding MiniTest
Commits on Jan 7, 2013
  1. @mjankowski

    Allow Rails 3.1 to select the 'turn' gem it wants to use

    mjankowski committed
    Rails 3.1.x has code which checks which version of ruby is being run,
    and based on the result, selects a version of turn.
    
    For 1.9.3+, it selects "~> 0.8.3"; for everything else, it selects "0.8.2".
    
    If we remove turn from the Appraisals, but have travis install both versions
    that rails might potentially need, the in-generated-app Gemfile building should
    work correctly.
  2. @mjankowski

    Newer versions of activerecord-jdbcsqlite3-adapter work without a spe…

    mjankowski committed
    …cially named db driver in database.yml
  3. @mjankowski
Commits on Jan 4, 2013
  1. @mjankowski

    Allow the rails 3.1 appraisal to select the exact version of turn it …

    mjankowski committed
    …needs, dont install before hand
  2. @mjankowski
  3. @mjankowski
  4. @mjankowski
Commits on Dec 21, 2012
  1. @mjankowski

    Instead of modifying the environment, run bundle install in a new pro…

    mjankowski committed
    …cess
    
    JRuby does not support setting/unsetting environment variables.
    
    Thus, we will launch an entirely new process without the parents env when
    we run `bundle install` inside the generated rails apps, forcing them to
    use their own Gemfile, instead of the BUNDLE_GEMFILE setting from the main
    gem codebase.
  2. @mjankowski
Commits on Dec 20, 2012
  1. @mjankowski
Commits on Dec 19, 2012
  1. @mjankowski

    Rails 3.1 adds the Turn gem to the gemfile, which impacts the format …

    mjankowski committed
    …that results are reported in, and we must verify that format
  2. @mjankowski

    Improve the way we switch between project Gemfile and appraisal gemfiles

    mjankowski committed
    Previously, the railties required by the project gemspec was in conflict with
    the rails versions being pulled in by Appraisal.
    
    There were situations where a newer rails app was generated by `rails new...`
    even though the Appraisal gemfiles/ value should have been setting it correctly.
    
    We need to be able to use the versions of things specified in the appraisal gemfiles/
    specify the version of rails for the initial generation of the applications,
    but subsequently allow those applications to point to the `Gemfile` within
    the newly generated rails apps, rather than wherever BUNDLE_GEMFILE was previously
    set by Appraisal.
Something went wrong with that request. Please try again.