Route block parameter causes Rails3 warning #8

Closed
brycethornton opened this Issue Aug 1, 2010 · 3 comments

Projects

None yet

4 participants

@brycethornton

This line in config/routes.rb:

Rails.application.routes.draw do |map|

should be:

Rails.application.routes.draw do

in order to avoid this warning in rails3:

DEPRECATION WARNING: You are using the old router DSL which will be removed in Rails 3.1. Please check how to update your routes file at: http://www.engineyard.com/blog/2010/the-lowdown-on-routes-in-rails-3/. (called from initialize at /Users/bryce/.rvm/gems/ruby-1.8.7-p248/bundler/gems/rails-d69949e/actionpack/lib/action_dispatch/routing/deprecated_mapper.rb:33)

I ran into this too and wondered where the deprecation warning was coming from. I've fixed this here: http://github.com/louismrose/flutie/commit/7dc8054edcde06e6bae61197c3929154cf2cc603

hemju commented Sep 1, 2010

The issue was reported a month ago, the fix is quite obvious and Rails 3 is out, so could this please get fixed in the master?

Owner

This was fixed here - ae687ae

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment