* Create new high_volgate module * Update README with override instructions * Require concerns directory for rails 3 or lower
overriding with a local PagesController that the default HighVoltage routes must be disabled (otherwise results in a routing conflict).
Force `bundle install` in install step Travis will now runs `bundle install --deployment` if it detects that the project has `Gemfile.lock`. However, there's a problem in Bundler deployment install that cause it not installing `bundler` gem into `vendor/bundle` directory, which causes `require 'bundler'` to fail.
* Update NEWS file
* There were issues with activesupport 4 and Ruby 1.9.2 https://travis-ci.org/thoughtbot/high_voltage/jobs/9169087
* Remove legacy style routing from README * Remove specs for older style routing * Update syntax highlighting in README
* Run certian versions Rails against Ruby 2.0 * Remove Rails 3.0.20 from CI
* Remove Ruby 1.8.7 support * Update Rails version to 4.0.0
Removed unused line from spec_helper.
lib/high_voltage.rb should be able to be required.
Use older version of capybara.
Removed trailing whitespace.
The previous commit message is enough.
Because it's evil and evil must be purged.
Ruby versions older than 1.9.3 can't use capybara > 2.0.3. Travis-provided error: Gem::InstallError: capybara requires Ruby version >= 1.9.3. An error occurred while installing capybara (2.1.0), and Bundler cannot continue. Make sure that `gem install capybara -v '2.1.0'` succeeds before bundling.
high_voltage.rb uses mattr_accessor methods, which are provided by active_support. Normally these methods are provided by having Rails ran beforehand, but this meant that high_voltage couldn't be loaded alone. Added necessary require to address this.