Skip to content
This repository

Oct 04, 2013

  1. Harlow Ward

    Bump to 2.0.0

    harlow authored
  2. Gasparyan Arsen

    Move PagesController code into a module

    * Create new high_volgate module
    * Update README with override instructions
    * Require concerns directory for rails 3 or lower
    frootloops authored harlow committed

Oct 01, 2013

  1. krsyoung

    Updated the README.md to provide a reminder to the user that when

    overriding with a local PagesController that the default HighVoltage
    routes must be disabled (otherwise results in a routing conflict).
    krsyoung authored harlow committed

Aug 31, 2013

  1. David Underwood

    Removes wayward apostrophe

    davefp authored

Aug 04, 2013

  1. Harlow Ward

    Fix Travis build

    Force `bundle install` in install step
    
    Travis will now runs `bundle install --deployment` if it detects that
    the project has `Gemfile.lock`. However, there's a problem in Bundler
    deployment install that cause it not installing `bundler` gem into
    `vendor/bundle` directory, which causes `require 'bundler'` to fail.
    harlow authored

Jul 25, 2013

  1. Harlow Ward

    Add MIT license to gemspec

    harlow authored

Jul 19, 2013

  1. Harlow Ward

    Bump to 1.2.4

    * Update NEWS file
    harlow authored
  2. Harlow Ward

    Specify activesupport version for Ruby 1.9.2

    * There were issues with activesupport 4 and Ruby 1.9.2
    
    https://travis-ci.org/thoughtbot/high_voltage/jobs/9169087
    harlow authored

Jul 17, 2013

  1. Harlow Ward

    Clean up Appraisals and Rake

    harlow authored
  2. Harlow Ward

    Update for Rails 4 compatibility

    * Remove legacy style routing from README
    * Remove specs for older style routing
    * Update syntax highlighting in README
    harlow authored

Jul 16, 2013

  1. Harlow Ward

    Update Travis CI Ruby and Rails versions

    * Run certian versions Rails against Ruby 2.0
    * Remove Rails 3.0.20 from CI
    harlow authored
  2. Ildar Manzhikov

    Updated README

    manzhikov authored harlow committed

Jul 08, 2013

  1. Harlow Ward

    Bump Rails version, and remove Ruby 1.8.7

    * Remove Ruby 1.8.7 support
    * Update Rails version to 4.0.0
    harlow authored
  2. Ildar Manzhikov

    Rails 4 caching compatible

    manzhikov authored

Jun 28, 2013

  1. Mason Fischer

    Allow page and action caching

Jun 15, 2013

  1. Harlow Ward

    Bump to 1.2.3

    harlow authored

May 15, 2013

  1. Arun Agrawal

    Add rails 4.0.0.rc1 to appraisals, upgraded others

    closes #77
    arunagw authored

May 10, 2013

  1. Mikael Muszynski

    Merge pull request #73 from thoughtbot/mm-spec_helper-tweak

    Removed unused line from spec_helper.
    linduxed authored
  2. Mikael Muszynski

    Merge pull request #72 from thoughtbot/mm-mattr_accessor-requiring

    lib/high_voltage.rb should be able to be required.
    linduxed authored
  3. Mikael Muszynski

    Merge pull request #75 from thoughtbot/mm-old_ruby-fix

    Use older version of capybara.
    linduxed authored
  4. Mikael Muszynski

    Merge pull request #76 from thoughtbot/mm-remove_trailing_whitespace

    Removed trailing whitespace.
    linduxed authored
  5. Mikael Muszynski

    Remove superfluous comment.

    The previous commit message is enough.
    linduxed authored

May 08, 2013

  1. Mikael Muszynski

    Removed trailing whitespace.

    Because it's evil and evil must be purged.
    linduxed authored
  2. Mikael Muszynski

    Use older version of capybara.

    Ruby versions older than 1.9.3 can't use capybara > 2.0.3.
    
    Travis-provided error:
    
        Gem::InstallError: capybara requires Ruby version >= 1.9.3.
        An error occurred while installing capybara (2.1.0), and Bundler
        cannot continue.
        Make sure that `gem install capybara -v '2.1.0'` succeeds before
        bundling.
    linduxed authored
  3. Mikael Muszynski

    Removed unused line from spec_helper.

    linduxed authored

May 07, 2013

  1. Mikael Muszynski

    Made the main library file loadable.

    high_voltage.rb uses mattr_accessor methods, which are provided by
    active_support. Normally these methods are provided by having Rails ran
    beforehand, but this meant that high_voltage couldn't be loaded alone.
    
    Added necessary require to address this.
    linduxed authored

Mar 18, 2013

  1. Harlow Ward

    Remove unloadable from controller

    harlow authored

Mar 15, 2013

  1. Johannes Faigle

    Fix markdown rendering

    jayeff authored

Mar 02, 2013

  1. Matt Jankowski

    Set eager load false to avoid rails4 warning

    mjankowski authored
  2. Matt Jankowski

    Update match to get in routes and docs

    mjankowski authored
  3. Matt Jankowski

    Avoid rails4 whiny_nils deprecation warning in the fake app

    mjankowski authored
  4. Matt Jankowski

    Allow rails4 to fail

    mjankowski authored
  5. Matt Jankowski

    Add rails 4.0.0.beta to appraisals

    mjankowski authored
  6. Matt Jankowski

    Bump rails versions in Appraisals

    mjankowski authored

Feb 17, 2013

  1. Harlow Ward

    Bump to 1.2.2

    harlow authored
Something went wrong with that request. Please try again.