Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Use older version of capybara. #75

Merged
merged 2 commits into from May 10, 2013

Conversation

Projects
None yet
3 participants
Contributor

linduxed commented May 8, 2013

Ruby versions older than 1.9.3 can't use capybara > 2.0.3.

Travis-provided error:

Gem::InstallError: capybara requires Ruby version >= 1.9.3.
An error occurred while installing capybara (2.1.0), and Bundler
cannot continue.
Make sure that gem install capybara -v '2.1.0' succeeds before
bundling.

Use older version of capybara.
Ruby versions older than 1.9.3 can't use capybara > 2.0.3.

Travis-provided error:

    Gem::InstallError: capybara requires Ruby version >= 1.9.3.
    An error occurred while installing capybara (2.1.0), and Bundler
    cannot continue.
    Make sure that `gem install capybara -v '2.1.0'` succeeds before
    bundling.

@harlow harlow and 2 others commented on an outdated diff May 8, 2013

high_voltage.gemspec
@@ -17,6 +17,7 @@ Gem::Specification.new do |s|
s.add_development_dependency("appraisal")
s.add_development_dependency("rspec-rails")
- s.add_development_dependency("capybara", ">= 0.4.0")
+ # Ruby version < 1.9.3 can't install capybara > 2.0.3.
@harlow

harlow May 8, 2013

Collaborator

Can we remove this comment? I'd rather have this in the README if its an important note for < 1.9.3 users.

@linduxed

linduxed May 8, 2013

Contributor

I'll move it, no problem.

On 2013-05-08 19:54, Harlow Ward wrote:

@@ -17,6 +17,7 @@ Gem::Specification.new do |s|

s.add_development_dependency("appraisal")
s.add_development_dependency("rspec-rails")

  • s.add_development_dependency("capybara", ">= 0.4.0")
  • Ruby version < 1.9.3 can't install capybara > 2.0.3.

Can we remove this comment? I'd rather have this in the README if its an important note for < 1.9.3 users.


Reply to this email directly or view it on GitHub:
https://github.com/thoughtbot/high_voltage/pull/75/files#r4139449

@linduxed

linduxed May 9, 2013

Contributor

After reviewing this, I'm thinking that adding this information to the README would be weird, considering this is a change that doesn't concern the user, only the potential developer.

In this scenario (since you want the comment gone), would the already provided commit message be sufficient information on the subject?

@mike-burns

mike-burns May 10, 2013

Owner

The goal of this comment is to explain when this = 2.0.3 restriction can be removed. That is, at some point a developer will notice that the capybara that this is tested against is out of date, and will look to see why and whether they can upgrade.

I'm on board with either a comment like this or a detailed commit message. Putting notes like this in the README doesn't make a ton of sense for the end user and is more likely to be overlooked by a developer.

Remove superfluous comment.
The previous commit message is enough.
Collaborator

harlow commented May 10, 2013

👍 looks great.

linduxed added a commit that referenced this pull request May 10, 2013

@linduxed linduxed merged commit fc4fa60 into master May 10, 2013

1 check passed

default The Travis CI build passed
Details

@linduxed linduxed deleted the mm-old_ruby-fix branch May 10, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment