Skip to content
Newer
Older
100644 33 lines (28 sloc) 1.17 KB
93b3a9d @gabebw Initial commit
gabebw authored
1 # -*- encoding: utf-8 -*-
2 $:.push File.expand_path("../lib", __FILE__)
3 require "kumade/version"
4
5 Gem::Specification.new do |s|
6 s.name = "kumade"
7 s.version = Kumade::VERSION
0b62209 @nickrivadeneira fix license, bump to 0.0.5
nickrivadeneira authored
8 s.authors = ["Gabe Berke-Williams", "thoughtbot"]
9 s.email = ["gabe@thoughtbot.com", "support@thoughtbot.com"]
cecdf2e @gabebw Update summary and homepage.
gabebw authored
10 s.homepage = "http://thoughtbot.com/community/"
11 s.summary = %q{A well-tested script for easy deploying to Heroku}
d00c206 @gabebw Description is the same as the summary
gabebw authored
12 s.description = s.summary
93b3a9d @gabebw Initial commit
gabebw authored
13
14 s.files = `git ls-files`.split("\n")
15 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
16 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
17 s.require_paths = ["lib"]
7c3467b @gabebw Add development dependencies
gabebw authored
18
d51f48b @gabebw Depend on heroku ~> 2.0
gabebw authored
19 s.add_dependency('heroku', '~> 2.0')
3fd4476 @tapajos Ops...
tapajos authored
20 s.add_dependency('rake', '>= 0.8.7')
866f946 @tapajos Fix issue 37 using Cocaine
tapajos authored
21 s.add_dependency('cocaine', '>= 0.2.0')
1808c1e @gabebw Rails is a dependency.
gabebw authored
22 s.add_dependency('rails', '>= 2')
5145a35 @gabebw Heroku is a dependency
gabebw authored
23
7c3467b @gabebw Add development dependencies
gabebw authored
24 s.add_development_dependency('rspec', '~> 2.6.0')
25 s.add_development_dependency('cucumber', '~> 1.0.2')
26 s.add_development_dependency('aruba', '~> 0.4.3')
6e7e5b4 @gabebw Support for packaging with Jammit
gabebw authored
27 s.add_development_dependency('jammit', '~> 0.6.3')
57a4c7f @gabebw Let's use Mocha.
gabebw authored
28 s.add_development_dependency('bourne')
e260283 @gabebw Install SimpleCov if on 1.9.x
gabebw authored
29 if RUBY_VERSION >= '1.9.0'
30 s.add_development_dependency('simplecov')
31 end
93b3a9d @gabebw Initial commit
gabebw authored
32 end
Something went wrong with that request. Please try again.