Permalink
Browse files

Force gcc-4.2 compiler when installing Ruby

Avoid errors like:

    st.c:520:35: error: implicit conversion loses integer precision:
    'st_index_t' (aka 'unsigned long') to 'int' [-Werror,-Wshorten-64-to-32]
    i = table->num_entries++; ~ ~~~~~~~~~~~~~~~~~~^~

rbenv/ruby-build#287
  • Loading branch information...
1 parent 2ce705b commit 20cad6b71f257f87c563a45ea19388e16c39f862 @croaky croaky committed Feb 25, 2013
Showing with 1 addition and 1 deletion.
  1. +1 −1 mac
View
2 mac
@@ -72,7 +72,7 @@ echo "Installing ruby-build for installing Rubies ..."
successfully brew install ruby-build
echo "Installing Ruby 1.9.3-p392 ..."
- successfully rbenv install 1.9.3-p392
+ successfully CC=gcc-4.2 rbenv install 1.9.3-p392
echo "Setting Ruby 1.9.3-p392 as global default Ruby ..."
successfully rbenv global 1.9.3-p392

0 comments on commit 20cad6b

Please sign in to comment.