Permalink
Browse files

Add libreadline-dev to linux install

Without libreadline-dev installed, IRB and the rails console won't
function properly.
  • Loading branch information...
1 parent 01ee224 commit 370499adb0a7b579795715371d5d41d2b36e4393 Dan Collis-Puro committed Oct 4, 2013
Showing with 2 additions and 2 deletions.
  1. +1 −1 linux
  2. +1 −1 linux-components/debian-derivative-packages
View
2 linux
@@ -52,7 +52,7 @@ fancy_echo "Installing base ruby build dependencies ..."
sudo aptitude build-dep -y ruby1.9.3
fancy_echo "Installing libraries for common gem dependencies ..."
- sudo aptitude install -y libxslt1-dev libcurl4-openssl-dev libksba8 libksba-dev libqtwebkit-dev
+ sudo aptitude install -y libxslt1-dev libcurl4-openssl-dev libksba8 libksba-dev libqtwebkit-dev libreadline-dev
fancy_echo "Installing Postgres, a good open source relational database ..."
sudo aptitude install -y postgresql postgresql-server-dev-all
@@ -5,7 +5,7 @@ fancy_echo "Installing base ruby build dependencies ..."
sudo aptitude build-dep -y ruby1.9.3
fancy_echo "Installing libraries for common gem dependencies ..."
- sudo aptitude install -y libxslt1-dev libcurl4-openssl-dev libksba8 libksba-dev libqtwebkit-dev
+ sudo aptitude install -y libxslt1-dev libcurl4-openssl-dev libksba8 libksba-dev libqtwebkit-dev libreadline-dev
fancy_echo "Installing Postgres, a good open source relational database ..."
sudo aptitude install -y postgresql postgresql-server-dev-all

0 comments on commit 370499a

Please sign in to comment.