Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Remove capybara requirement

  • Loading branch information...
commit 4c73f24504ae246ec9dbe78ca00cecfce7f28ef8 1 parent 74a8e22
@mjankowski mjankowski authored
View
20 Gemfile.lock
@@ -39,15 +39,6 @@ GEM
rake
arel (3.0.2)
builder (3.0.0)
- capybara (1.1.2)
- mime-types (>= 1.16)
- nokogiri (>= 1.3.3)
- rack (>= 1.0.0)
- rack-test (>= 0.5.4)
- selenium-webdriver (~> 2.0)
- xpath (~> 0.1.4)
- childprocess (0.3.1)
- ffi (~> 1.0.6)
diff-lcs (1.1.3)
erubis (2.7.0)
factory_girl (3.0.0)
@@ -55,7 +46,6 @@ GEM
factory_girl_rails (3.0.0)
factory_girl (~> 3.0.0)
railties (>= 3.0.0)
- ffi (1.0.11)
hike (1.2.1)
i18n (0.6.0)
journey (1.0.3)
@@ -69,7 +59,6 @@ GEM
mocha (0.12.3)
metaclass (~> 0.0.1)
multi_json (1.2.0)
- nokogiri (1.5.2)
polyglot (0.3.3)
rack (1.4.1)
rack-cache (1.2)
@@ -109,12 +98,6 @@ GEM
activesupport (>= 3.0)
railties (>= 3.0)
rspec (~> 2.9.0)
- rubyzip (0.9.6.1)
- selenium-webdriver (2.20.0)
- childprocess (>= 0.2.5)
- ffi (~> 1.0)
- multi_json (~> 1.0)
- rubyzip
sprockets (2.1.2)
hike (~> 1.2)
rack (~> 1.0)
@@ -125,15 +108,12 @@ GEM
polyglot
polyglot (>= 0.3.1)
tzinfo (0.3.32)
- xpath (0.1.4)
- nokogiri (~> 1.3)
PLATFORMS
ruby
DEPENDENCIES
appraisal (~> 0.5.1)
- capybara (>= 0.4.0)
factory_girl_rails
mocha (= 0.12.3)
pacecar!
View
1  pacecar.gemspec
@@ -20,7 +20,6 @@ Gem::Specification.new do |s|
s.add_dependency("activerecord", ">= 3.0.0")
s.add_development_dependency("appraisal", "~> 0.5.1")
- s.add_development_dependency("capybara", ">= 0.4.0")
s.add_development_dependency("mocha", "0.12.3")
s.add_development_dependency("rspec-rails", ">= 2.9.0")
s.add_development_dependency("factory_girl_rails")
View
1  spec/integration/navigation_spec.rb
@@ -1,7 +1,6 @@
require 'spec_helper'
describe "Navigation" do
- include Capybara::DSL
it "should be a valid app" do
::Rails.application.should be_a(Dummy::Application)
View
5 spec/spec_helper.rb
@@ -11,11 +11,6 @@
Rails.backtrace_cleaner.remove_silencers!
-# Configure capybara for integration testing
-require "capybara/rails"
-Capybara.default_driver = :rack_test
-Capybara.default_selector = :css
-
# Load support files
Dir["#{File.dirname(__FILE__)}/support/**/*.rb"].each { |f| require f }
Please sign in to comment.
Something went wrong with that request. Please try again.