Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Bump rails Appraisal versions to 3.2.8, 3.1.8, 3.0.17

  • Loading branch information...
commit 9b177ad95226c8afcaafb704b4bbc363d7d652a7 1 parent d21b17f
@mjankowski mjankowski authored
View
24 .travis.yml
@@ -3,18 +3,18 @@ rvm:
- 1.9.2
- 1.9.3
gemfile:
- - gemfiles/rails-3.0.12-database-mysql.gemfile
- - gemfiles/rails-3.0.12-database-mysql2.gemfile
- - gemfiles/rails-3.0.12-database-pg.gemfile
- - gemfiles/rails-3.0.12-database-sqlite3.gemfile
- - gemfiles/rails-3.1.4-database-mysql.gemfile
- - gemfiles/rails-3.1.4-database-mysql2.gemfile
- - gemfiles/rails-3.1.4-database-pg.gemfile
- - gemfiles/rails-3.1.4-database-sqlite3.gemfile
- - gemfiles/rails-3.2.3-database-mysql.gemfile
- - gemfiles/rails-3.2.3-database-mysql2.gemfile
- - gemfiles/rails-3.2.3-database-pg.gemfile
- - gemfiles/rails-3.2.3-database-sqlite3.gemfile
+ - gemfiles/rails-3.0.17-database-mysql.gemfile
+ - gemfiles/rails-3.0.17-database-mysql2.gemfile
+ - gemfiles/rails-3.0.17-database-pg.gemfile
+ - gemfiles/rails-3.0.17-database-sqlite3.gemfile
+ - gemfiles/rails-3.1.8-database-mysql.gemfile
+ - gemfiles/rails-3.1.8-database-mysql2.gemfile
+ - gemfiles/rails-3.1.8-database-pg.gemfile
+ - gemfiles/rails-3.1.8-database-sqlite3.gemfile
+ - gemfiles/rails-3.2.8-database-mysql.gemfile
+ - gemfiles/rails-3.2.8-database-mysql2.gemfile
+ - gemfiles/rails-3.2.8-database-pg.gemfile
+ - gemfiles/rails-3.2.8-database-sqlite3.gemfile
before_script:
- "mysql -e 'create database pacecar_test;' >/dev/null"
- "psql -c 'create database pacecar_test;' -U postgres >/dev/null"
View
4 Appraisals
@@ -1,4 +1,4 @@
-rails_versions = ['3.0.15', '3.1.6', '3.2.6']
+rails_versions = ['3.0.17', '3.1.8', '3.2.8']
database_drivers = ['mysql', 'pg', 'sqlite3']
rails_versions.each do |rails_version|
@@ -12,7 +12,7 @@ rails_versions.each do |rails_version|
end
# The mysql2 gem needed by Rails changes with Rails versions
-rails_to_mysql2_mappings = { '3.2.6' => '0.3.11', '3.1.6' => '0.3.11', '3.0.15' => '0.2.18' }
+rails_to_mysql2_mappings = { '3.2.8' => '0.3.11', '3.1.8' => '0.3.11', '3.0.17' => '0.2.18' }
rails_to_mysql2_mappings.each do |rails_gem_version, mysql2_gem_version|
appraise "rails-#{rails_gem_version}-database-mysql2" do
gem 'rails', rails_gem_version
View
2  gemfiles/rails-3.0.15-database-mysql.gemfile → gemfiles/rails-3.0.17-database-mysql.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.0.15"
+gem "rails", "3.0.17"
gem "mysql"
gem "pacecar", :path=>"../"
View
2  ...iles/rails-3.0.15-database-mysql2.gemfile → ...iles/rails-3.0.17-database-mysql2.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.0.15"
+gem "rails", "3.0.17"
gem "mysql2", "0.2.18"
gem "pacecar", :path=>"../"
View
2  gemfiles/rails-3.0.15-database-pg.gemfile → gemfiles/rails-3.0.17-database-pg.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.0.15"
+gem "rails", "3.0.17"
gem "pg"
gem "pacecar", :path=>"../"
View
2  ...les/rails-3.0.15-database-sqlite3.gemfile → ...les/rails-3.0.17-database-sqlite3.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.0.15"
+gem "rails", "3.0.17"
gem "sqlite3"
gem "pacecar", :path=>"../"
View
2  gemfiles/rails-3.1.6-database-mysql.gemfile → gemfiles/rails-3.1.8-database-mysql.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.1.6"
+gem "rails", "3.1.8"
gem "mysql"
gem "pacecar", :path=>"../"
View
2  gemfiles/rails-3.1.6-database-mysql2.gemfile → gemfiles/rails-3.1.8-database-mysql2.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.1.6"
+gem "rails", "3.1.8"
gem "mysql2", "0.3.11"
gem "pacecar", :path=>"../"
View
2  gemfiles/rails-3.2.6-database-pg.gemfile → gemfiles/rails-3.1.8-database-pg.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.2.6"
+gem "rails", "3.1.8"
gem "pg"
gem "pacecar", :path=>"../"
View
2  ...iles/rails-3.1.6-database-sqlite3.gemfile → ...iles/rails-3.1.8-database-sqlite3.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.1.6"
+gem "rails", "3.1.8"
gem "sqlite3"
gem "pacecar", :path=>"../"
View
2  gemfiles/rails-3.2.6-database-mysql.gemfile → gemfiles/rails-3.2.8-database-mysql.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.2.6"
+gem "rails", "3.2.8"
gem "mysql"
gem "pacecar", :path=>"../"
View
2  gemfiles/rails-3.2.6-database-mysql2.gemfile → gemfiles/rails-3.2.8-database-mysql2.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.2.6"
+gem "rails", "3.2.8"
gem "mysql2", "0.3.11"
gem "pacecar", :path=>"../"
View
2  gemfiles/rails-3.1.6-database-pg.gemfile → gemfiles/rails-3.2.8-database-pg.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.1.6"
+gem "rails", "3.2.8"
gem "pg"
gem "pacecar", :path=>"../"
View
2  ...iles/rails-3.2.6-database-sqlite3.gemfile → ...iles/rails-3.2.8-database-sqlite3.gemfile
@@ -2,7 +2,7 @@
source "http://rubygems.org"
-gem "rails", "3.2.6"
+gem "rails", "3.2.8"
gem "sqlite3"
gem "pacecar", :path=>"../"
Please sign in to comment.
Something went wrong with that request. Please try again.