This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

raise if none of the expected database gems are present

  • Loading branch information...
1 parent a9f525d commit 9e69b39b74a2f3c76dfe7b4f4d22733ad18f40e7 @mjankowski mjankowski committed Apr 2, 2012
Showing with 1 addition and 1 deletion.
  1. +1 −1 spec/dummy/config/database.yml
@@ -36,7 +36,7 @@ pg: &pg
# This is because of appraisal - find the gem which was loaded, and use that driver
test:
- <<: *<%= Gem.loaded_specs.keys.select { |key| ['sqlite3', 'mysql', 'mysql2', 'pg'].include? key }.first %>
+ <<: *<%= Gem.loaded_specs.keys.select { |key| ['sqlite3', 'mysql', 'mysql2', 'pg'].include? key }.first or raise('Database gem was not loaded') %>
production:
adapter: sqlite3

0 comments on commit 9e69b39

Please sign in to comment.