Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 54 lines (46 sloc) 2.045 kb
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
1 $LOAD_PATH.push File.expand_path("../lib", __FILE__)
bf33af3 Nick Ragaz put version in its own file
nragaz authored
2 require 'paperclip/version'
7480516 Jon Yurek Version 2.2.0
jyurek authored
3
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
4 Gem::Specification.new do |s|
eefaa9c Jon Yurek The gemspec is a separate file which can handle itself.
jyurek authored
5 s.name = "paperclip"
6 s.version = Paperclip::VERSION
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
7 s.platform = Gem::Platform::RUBY
eefaa9c Jon Yurek The gemspec is a separate file which can handle itself.
jyurek authored
8 s.author = "Jon Yurek"
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
9 s.email = ["jyurek@thoughtbot.com"]
3695eaf Gabe Berke-Williams Fix gem homepage
gabebw authored
10 s.homepage = "https://github.com/thoughtbot/paperclip"
eefaa9c Jon Yurek The gemspec is a separate file which can handle itself.
jyurek authored
11 s.summary = "File attachments as attributes for ActiveRecord"
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
12 s.description = "Easy upload management for ActiveRecord"
13
eefaa9c Jon Yurek The gemspec is a separate file which can handle itself.
jyurek authored
14 s.rubyforge_project = "paperclip"
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
15
16 s.files = `git ls-files`.split("\n")
17 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
18 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
19 s.require_paths = ["lib"]
20
b3a63ed Prem Sichanugrist Add Upgrading note
sikachu authored
21 if File.exists?('UPGRADING')
22 s.post_install_message = File.read("UPGRADING")
23 end
24
eefaa9c Jon Yurek The gemspec is a separate file which can handle itself.
jyurek authored
25 s.requirements << "ImageMagick"
efd7032 Prem Sichanugrist Explicitly say that we require at least Ruby 1.9.2
sikachu authored
26 s.required_ruby_version = ">= 1.9.2"
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
27
e83f88f Prem Sichanugrist Add AttachementSizeValidator
sikachu authored
28 s.add_dependency('activerecord', '>= 3.0.0')
29 s.add_dependency('activemodel', '>= 3.0.0')
30 s.add_dependency('activesupport', '>= 3.0.0')
d15d8d8 Jon Yurek Use Cocaine 0.4.0's new API
jyurek authored
31 s.add_dependency('cocaine', '~> 0.4.0')
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
32 s.add_dependency('mime-types')
33
34 s.add_development_dependency('shoulda')
a596c01 Prem Sichanugrist Unlock Appraisal dependency
sikachu authored
35 s.add_development_dependency('appraisal')
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
36 s.add_development_dependency('mocha')
c9ee8b9 Jon Yurek Specify SSE correctly
jyurek authored
37 s.add_development_dependency('aws-sdk', '>= 1.2.0')
89c8d11 Jon Yurek Adds IO adapters to abstract the things that can be assigned.
jyurek authored
38 s.add_development_dependency('bourne')
39 s.add_development_dependency('sqlite3', '~> 1.3.4')
ccfcc22 Prem Sichanugrist Bump to 3.1.0
sikachu authored
40 s.add_development_dependency('cucumber', '~> 1.2.1')
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
41 s.add_development_dependency('aruba')
ec1aa8b Prem Sichanugrist Update development dependency
sikachu authored
42 s.add_development_dependency('nokogiri')
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
43 s.add_development_dependency('capybara')
44 s.add_development_dependency('bundler')
45 s.add_development_dependency('cocaine', '~> 0.2')
86dc49b Jon Yurek Update some dependencies
jyurek authored
46 s.add_development_dependency('fog', '>= 1.4.0', "< 1.7.0")
89c8d11 Jon Yurek Adds IO adapters to abstract the things that can be assigned.
jyurek authored
47 s.add_development_dependency('pry')
48 s.add_development_dependency('launchy')
49 s.add_development_dependency('rake')
49c8460 Gabe Berke-Williams Use Bundler gem conventions.
gabebw authored
50 s.add_development_dependency('fakeweb')
813c8c8 Mike Burns The tests depend on railties and actionmailer
mike-burns authored
51 s.add_development_dependency('railties')
52 s.add_development_dependency('actionmailer')
30ebb74 Jon Yurek Changes for gem building on github.
jyurek authored
53 end
Something went wrong with that request. Please try again.