Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 51 lines (45 sloc) 2.038 kb
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
1 $LOAD_PATH.push File.expand_path("../lib", __FILE__)
bf33af3 @nragaz put version in its own file
nragaz authored
2 require 'paperclip/version'
7480516 @jyurek Version 2.2.0
jyurek authored
3
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
4 Gem::Specification.new do |s|
eefaa9c @jyurek The gemspec is a separate file which can handle itself.
jyurek authored
5 s.name = "paperclip"
6 s.version = Paperclip::VERSION
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
7 s.platform = Gem::Platform::RUBY
eefaa9c @jyurek The gemspec is a separate file which can handle itself.
jyurek authored
8 s.author = "Jon Yurek"
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
9 s.email = ["jyurek@thoughtbot.com"]
3695eaf @gabebw Fix gem homepage
gabebw authored
10 s.homepage = "https://github.com/thoughtbot/paperclip"
eefaa9c @jyurek The gemspec is a separate file which can handle itself.
jyurek authored
11 s.summary = "File attachments as attributes for ActiveRecord"
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
12 s.description = "Easy upload management for ActiveRecord"
65cc5c7 @jyurek Specify MIT license in the gemspec
jyurek authored
13 s.license = "MIT"
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
14
15 s.files = `git ls-files`.split("\n")
1f3a746 @jyurek Convert all of the tests from test/unit to RSpec
jyurek authored
16 s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
17 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
18 s.require_paths = ["lib"]
19
eefaa9c @jyurek The gemspec is a separate file which can handle itself.
jyurek authored
20 s.requirements << "ImageMagick"
efd7032 @sikachu Explicitly say that we require at least Ruby 1.9.2
sikachu authored
21 s.required_ruby_version = ">= 1.9.2"
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
22
e83f88f @sikachu Add AttachementSizeValidator
sikachu authored
23 s.add_dependency('activemodel', '>= 3.0.0')
24 s.add_dependency('activesupport', '>= 3.0.0')
0f7380b @jyurek Update cocaine dependency
jyurek authored
25 s.add_dependency('cocaine', '~> 0.5.5')
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
26 s.add_dependency('mime-types')
2a0274d @scpike Prefer the mimemagic gem for content type detection
scpike authored
27 s.add_dependency('mimemagic', '0.3.0')
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
28
bf5b404 @johnnyshields Should be agnostic toward ActiveRecord; use ActiveModel where appropr…
johnnyshields authored
29 s.add_development_dependency('activerecord', '>= 3.0.0')
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
30 s.add_development_dependency('shoulda')
1f3a746 @jyurek Convert all of the tests from test/unit to RSpec
jyurek authored
31 s.add_development_dependency('rspec')
a596c01 @sikachu Unlock Appraisal dependency
sikachu authored
32 s.add_development_dependency('appraisal')
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
33 s.add_development_dependency('mocha')
21c2eb0 @schrockwell Updated gemspec to fix issue #1729
schrockwell authored
34 s.add_development_dependency('aws-sdk', '~> 1.6')
89c8d11 @jyurek Adds IO adapters to abstract the things that can be assigned.
jyurek authored
35 s.add_development_dependency('bourne')
e57dc34 @jyurek Update aws-sdk and cucumber gem versions.
jyurek authored
36 s.add_development_dependency('cucumber', '~> 1.3.18')
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
37 s.add_development_dependency('aruba')
ec1aa8b @sikachu Update development dependency
sikachu authored
38 s.add_development_dependency('nokogiri')
99cc533 @mike-burns Downgrade capybara for Ruby 1.9.2
mike-burns authored
39 # Ruby version < 1.9.3 can't install capybara > 2.0.3.
5e7570b @soramugi Legacy RSpec matcher to version up
soramugi authored
40 s.add_development_dependency('capybara')
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
41 s.add_development_dependency('bundler')
c893aa0 @jyurek We don't need to limit fog to <1.7.0
jyurek authored
42 s.add_development_dependency('fog', '~> 1.0')
89c8d11 @jyurek Adds IO adapters to abstract the things that can be assigned.
jyurek authored
43 s.add_development_dependency('launchy')
44 s.add_development_dependency('rake')
49c8460 @gabebw Use Bundler gem conventions.
gabebw authored
45 s.add_development_dependency('fakeweb')
813c8c8 @mike-burns The tests depend on railties and actionmailer
mike-burns authored
46 s.add_development_dependency('railties')
1da9e4d Fix bundler dependency resolution during development
Dan Collis-Puro authored
47 s.add_development_dependency('actionmailer', '>= 3.0.0')
1f3a746 @jyurek Convert all of the tests from test/unit to RSpec
jyurek authored
48 s.add_development_dependency('generator_spec')
9b2dd49 Move Timecop gem from Gemfile into gemspec
Adarsh Pandit authored
49 s.add_development_dependency('timecop')
30ebb74 @jyurek Changes for gem building on github.
jyurek authored
50 end
Something went wrong with that request. Please try again.