Permalink
Browse files

Changes for gem building on github.

  • Loading branch information...
1 parent 0f4be8a commit 30ebb746e45414b72d5aafb54a152b176ddd057c @jyurek jyurek committed Dec 10, 2008
Showing with 48 additions and 4 deletions.
  1. +10 −4 Rakefile
  2. +38 −0 paperclip.gemspec
View
@@ -46,19 +46,18 @@ task :clean do |t|
end
spec = Gem::Specification.new do |s|
- s.rubygems_version = "1.2.0"
s.name = "paperclip"
s.version = Paperclip::VERSION
s.author = "Jon Yurek"
s.email = "jyurek@thoughtbot.com"
- s.homepage = "http://www.thoughtbot.com/"
+ s.homepage = "http://www.thoughtbot.com/projects/paperclip"
s.platform = Gem::Platform::RUBY
s.summary = "File attachments as attributes for ActiveRecord"
s.files = FileList["README",
"LICENSE",
"Rakefile",
"init.rb",
- "{generators,lib,tasks,test}/**/*"].to_a
+ "{generators,lib,tasks,test,shoulda_macros}/**/*"].to_a
s.require_path = "lib"
s.test_files = FileList["test/**/test_*.rb"].to_a
s.rubyforge_project = "paperclip"
@@ -67,7 +66,7 @@ spec = Gem::Specification.new do |s|
s.rdoc_options << '--line-numbers' << '--inline-source'
s.requirements << "ImageMagick"
s.add_runtime_dependency 'right_aws'
- s.add_development_dependency 'Shoulda'
+ s.add_development_dependency 'thoughtbot-shoulda'
s.add_development_dependency 'mocha'
end
@@ -86,3 +85,10 @@ task :release => [:test, :sync_docs, :gem] do
spec.version,
File.join("pkg", "#{spec.name}-#{spec.version}.gem")
end
+
+desc "Generate a gemspec file for GitHub"
+task :gemspec do
+ File.open("#{spec.name}.gemspec", 'w') do |f|
+ f.write spec.to_ruby
+ end
+end
View
@@ -0,0 +1,38 @@
+Gem::Specification.new do |s|
+ s.name = %q{paperclip}
+ s.version = "2.1.4"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Jon Yurek"]
+ s.date = %q{2008-12-10}
+ s.email = %q{jyurek@thoughtbot.com}
+ s.extra_rdoc_files = ["README"]
+ s.files = ["README", "LICENSE", "Rakefile", "init.rb", "generators/paperclip", "generators/paperclip/paperclip_generator.rb", "generators/paperclip/templates", "generators/paperclip/templates/paperclip_migration.rb.erb", "generators/paperclip/USAGE", "lib/paperclip", "lib/paperclip/attachment.rb", "lib/paperclip/geometry.rb", "lib/paperclip/iostream.rb", "lib/paperclip/storage.rb", "lib/paperclip/thumbnail.rb", "lib/paperclip/upfile.rb", "lib/paperclip.rb", "tasks/paperclip_tasks.rake", "test/attachment_test.rb", "test/database.yml", "test/debug.log", "test/fixtures", "test/fixtures/12k.png", "test/fixtures/50x50.png", "test/fixtures/5k.png", "test/fixtures/bad.png", "test/fixtures/text.txt", "test/geometry_test.rb", "test/helper.rb", "test/integration_test.rb", "test/iostream_test.rb", "test/paperclip_test.rb", "test/s3.yml", "test/storage_test.rb", "test/thumbnail_test.rb", "shoulda_macros/paperclip.rb"]
+ s.has_rdoc = true
+ s.homepage = %q{http://www.thoughtbot.com/}
+ s.rdoc_options = ["--line-numbers", "--inline-source"]
+ s.require_paths = ["lib"]
+ s.requirements = ["ImageMagick"]
+ s.rubyforge_project = %q{paperclip}
+ s.rubygems_version = %q{1.2.0}
+ s.summary = %q{File attachments as attributes for ActiveRecord}
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 2
+
+ if current_version >= 3 then
+ s.add_runtime_dependency(%q<right_aws>, [">= 0"])
+ s.add_development_dependency(%q<thoughtbot-shoulda>, [">= 0"])
+ s.add_development_dependency(%q<mocha>, [">= 0"])
+ else
+ s.add_dependency(%q<right_aws>, [">= 0"])
+ s.add_dependency(%q<thoughtbot-shoulda>, [">= 0"])
+ s.add_dependency(%q<mocha>, [">= 0"])
+ end
+ else
+ s.add_dependency(%q<right_aws>, [">= 0"])
+ s.add_dependency(%q<thoughtbot-shoulda>, [">= 0"])
+ s.add_dependency(%q<mocha>, [">= 0"])
+ end
+end

0 comments on commit 30ebb74

Please sign in to comment.