Skip to content
Browse files

Bump all dependencies to the latest Rails version

This will fix the problem with Psych on the old version of Rails 2.x
  • Loading branch information...
1 parent 6d4252d commit 6cd951a59a2b2ed7de0aaed6fbbdfed431e9e9bd @sikachu sikachu committed
View
6 Appraisals
@@ -1,11 +1,11 @@
appraise "rails2" do
- gem "rails", "~>2.3.0"
+ gem "rails", "~> 2.3.12"
end
appraise "rails3" do
- gem "rails", "~>3.0.0"
+ gem "rails", "~> 3.0.9"
end
appraise "rails3_1" do
- gem "rails", "~>3.1.0.rc1"
+ gem "rails", "~> 3.1.0.rc4"
end
View
4 Gemfile.lock
@@ -36,9 +36,9 @@ GEM
nokogiri (>= 1.4.4)
ruby-hmac
formatador (0.1.4)
- gherkin (2.4.0)
+ gherkin (2.4.5)
json (>= 1.4.6)
- json (1.5.1)
+ json (1.5.3)
mime-types (1.16)
mocha (0.9.12)
net-ssh (2.1.4)
View
2 gemfiles/rails2.gemfile
@@ -13,5 +13,5 @@ gem "bundler"
gem "cocaine"
gem "mime-types"
gem "rdoc", :require=>false
-gem "rails", "~>2.3.0"
+gem "rails", "~> 2.3.12"
View
101 gemfiles/rails2.gemfile.lock
@@ -1,56 +1,91 @@
GEM
remote: http://rubygems.org/
specs:
- actionmailer (2.3.10)
- actionpack (= 2.3.10)
- actionpack (2.3.10)
- activesupport (= 2.3.10)
+ actionmailer (2.3.12)
+ actionpack (= 2.3.12)
+ actionpack (2.3.12)
+ activesupport (= 2.3.12)
rack (~> 1.1.0)
- activerecord (2.3.10)
- activesupport (= 2.3.10)
- activeresource (2.3.10)
- activesupport (= 2.3.10)
- activesupport (2.3.10)
- appraisal (0.1)
+ activerecord (2.3.12)
+ activesupport (= 2.3.12)
+ activeresource (2.3.12)
+ activesupport (= 2.3.12)
+ activesupport (2.3.12)
+ appraisal (0.3.7)
+ aruba (~> 0.4.2)
bundler
rake
+ aruba (0.4.3)
+ bcat (>= 0.6.1)
+ childprocess (>= 0.1.9)
+ cucumber (>= 0.10.7)
+ rdiscount (>= 1.6.8)
+ rspec (>= 2.6.0)
aws-s3 (0.6.2)
builder
mime-types
xml-simple
+ bcat (0.6.1)
+ rack (~> 1.0)
builder (3.0.0)
- cocaine (0.0.2)
- excon (0.5.7)
- fog (0.7.1)
+ childprocess (0.2.0)
+ ffi (~> 1.0.6)
+ cocaine (0.1.0)
+ cucumber (1.0.2)
+ builder (>= 2.1.2)
+ diff-lcs (>= 1.1.2)
+ gherkin (~> 2.4.5)
+ json (>= 1.4.6)
+ term-ansicolor (>= 1.0.5)
+ diff-lcs (1.1.2)
+ excon (0.6.5)
+ ffi (1.0.9)
+ fog (0.9.0)
builder
- excon (>= 0.5.7)
- formatador (>= 0.1.2)
+ excon (~> 0.6.1)
+ formatador (>= 0.1.3)
json
mime-types
- net-ssh (>= 2.0.23)
+ net-scp (>= 1.0.4)
+ net-ssh (>= 2.1.4)
nokogiri (>= 1.4.4)
ruby-hmac
- formatador (0.1.2)
- json (1.5.1)
+ formatador (0.2.0)
+ gherkin (2.4.5)
+ json (>= 1.4.6)
+ json (1.5.3)
mime-types (1.16)
- mocha (0.9.9)
- rake
- net-ssh (2.1.0)
- nokogiri (1.4.4)
- rack (1.1.0)
- rails (2.3.10)
- actionmailer (= 2.3.10)
- actionpack (= 2.3.10)
- activerecord (= 2.3.10)
- activeresource (= 2.3.10)
- activesupport (= 2.3.10)
+ mocha (0.9.12)
+ net-scp (1.0.4)
+ net-ssh (>= 1.99.1)
+ net-ssh (2.1.4)
+ nokogiri (1.5.0)
+ rack (1.1.2)
+ rails (2.3.12)
+ actionmailer (= 2.3.12)
+ actionpack (= 2.3.12)
+ activerecord (= 2.3.12)
+ activeresource (= 2.3.12)
+ activesupport (= 2.3.12)
rake (>= 0.8.3)
- rake (0.8.7)
+ rake (0.9.2)
+ rdiscount (1.6.8)
rdoc (3.8)
+ rspec (2.6.0)
+ rspec-core (~> 2.6.0)
+ rspec-expectations (~> 2.6.0)
+ rspec-mocks (~> 2.6.0)
+ rspec-core (2.6.4)
+ rspec-expectations (2.6.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.6.0)
ruby-hmac (0.4.0)
shoulda (2.11.3)
- sqlite3-ruby (1.3.2)
- xml-simple (1.0.12)
+ sqlite3 (1.3.3)
+ sqlite3-ruby (1.3.3)
+ sqlite3 (>= 1.3.3)
+ term-ansicolor (1.0.6)
+ xml-simple (1.1.0)
PLATFORMS
ruby
@@ -63,7 +98,7 @@ DEPENDENCIES
fog
mime-types
mocha
- rails (~> 2.3.0)
+ rails (~> 2.3.12)
rake
rdoc
shoulda
View
2 gemfiles/rails3.gemfile
@@ -13,5 +13,5 @@ gem "bundler"
gem "cocaine"
gem "mime-types"
gem "rdoc", :require=>false
-gem "rails", "~>3.0.0"
+gem "rails", "~> 3.0.9"
View
146 gemfiles/rails3.gemfile.lock
@@ -2,96 +2,132 @@ GEM
remote: http://rubygems.org/
specs:
abstract (1.0.0)
- actionmailer (3.0.3)
- actionpack (= 3.0.3)
- mail (~> 2.2.9)
- actionpack (3.0.3)
- activemodel (= 3.0.3)
- activesupport (= 3.0.3)
+ actionmailer (3.0.9)
+ actionpack (= 3.0.9)
+ mail (~> 2.2.19)
+ actionpack (3.0.9)
+ activemodel (= 3.0.9)
+ activesupport (= 3.0.9)
builder (~> 2.1.2)
erubis (~> 2.6.6)
- i18n (~> 0.4)
+ i18n (~> 0.5.0)
rack (~> 1.2.1)
- rack-mount (~> 0.6.13)
- rack-test (~> 0.5.6)
+ rack-mount (~> 0.6.14)
+ rack-test (~> 0.5.7)
tzinfo (~> 0.3.23)
- activemodel (3.0.3)
- activesupport (= 3.0.3)
+ activemodel (3.0.9)
+ activesupport (= 3.0.9)
builder (~> 2.1.2)
- i18n (~> 0.4)
- activerecord (3.0.3)
- activemodel (= 3.0.3)
- activesupport (= 3.0.3)
- arel (~> 2.0.2)
+ i18n (~> 0.5.0)
+ activerecord (3.0.9)
+ activemodel (= 3.0.9)
+ activesupport (= 3.0.9)
+ arel (~> 2.0.10)
tzinfo (~> 0.3.23)
- activeresource (3.0.3)
- activemodel (= 3.0.3)
- activesupport (= 3.0.3)
- activesupport (3.0.3)
- appraisal (0.1)
+ activeresource (3.0.9)
+ activemodel (= 3.0.9)
+ activesupport (= 3.0.9)
+ activesupport (3.0.9)
+ appraisal (0.3.7)
+ aruba (~> 0.4.2)
bundler
rake
- arel (2.0.4)
+ arel (2.0.10)
+ aruba (0.4.3)
+ bcat (>= 0.6.1)
+ childprocess (>= 0.1.9)
+ cucumber (>= 0.10.7)
+ rdiscount (>= 1.6.8)
+ rspec (>= 2.6.0)
aws-s3 (0.6.2)
builder
mime-types
xml-simple
+ bcat (0.6.1)
+ rack (~> 1.0)
builder (2.1.2)
- cocaine (0.0.2)
+ childprocess (0.2.0)
+ ffi (~> 1.0.6)
+ cocaine (0.1.0)
+ cucumber (1.0.2)
+ builder (>= 2.1.2)
+ diff-lcs (>= 1.1.2)
+ gherkin (~> 2.4.5)
+ json (>= 1.4.6)
+ term-ansicolor (>= 1.0.5)
+ diff-lcs (1.1.2)
erubis (2.6.6)
abstract (>= 1.0.0)
- excon (0.5.7)
- fog (0.7.1)
+ excon (0.6.5)
+ ffi (1.0.9)
+ fog (0.9.0)
builder
- excon (>= 0.5.7)
- formatador (>= 0.1.2)
+ excon (~> 0.6.1)
+ formatador (>= 0.1.3)
json
mime-types
- net-ssh (>= 2.0.23)
+ net-scp (>= 1.0.4)
+ net-ssh (>= 2.1.4)
nokogiri (>= 1.4.4)
ruby-hmac
- formatador (0.1.2)
- i18n (0.4.2)
- json (1.5.1)
- mail (2.2.10)
+ formatador (0.2.0)
+ gherkin (2.4.5)
+ json (>= 1.4.6)
+ i18n (0.5.0)
+ json (1.5.3)
+ mail (2.2.19)
activesupport (>= 2.3.6)
- i18n (~> 0.4.1)
+ i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.16)
- mocha (0.9.9)
- rake
- net-ssh (2.1.0)
- nokogiri (1.4.4)
+ mocha (0.9.12)
+ net-scp (1.0.4)
+ net-ssh (>= 1.99.1)
+ net-ssh (2.1.4)
+ nokogiri (1.5.0)
polyglot (0.3.1)
- rack (1.2.1)
- rack-mount (0.6.13)
+ rack (1.2.3)
+ rack-mount (0.6.14)
rack (>= 1.0.0)
- rack-test (0.5.6)
+ rack-test (0.5.7)
rack (>= 1.0)
- rails (3.0.3)
- actionmailer (= 3.0.3)
- actionpack (= 3.0.3)
- activerecord (= 3.0.3)
- activeresource (= 3.0.3)
- activesupport (= 3.0.3)
+ rails (3.0.9)
+ actionmailer (= 3.0.9)
+ actionpack (= 3.0.9)
+ activerecord (= 3.0.9)
+ activeresource (= 3.0.9)
+ activesupport (= 3.0.9)
bundler (~> 1.0)
- railties (= 3.0.3)
- railties (3.0.3)
- actionpack (= 3.0.3)
- activesupport (= 3.0.3)
+ railties (= 3.0.9)
+ railties (3.0.9)
+ actionpack (= 3.0.9)
+ activesupport (= 3.0.9)
rake (>= 0.8.7)
+ rdoc (~> 3.4)
thor (~> 0.14.4)
- rake (0.8.7)
+ rake (0.9.2)
+ rdiscount (1.6.8)
rdoc (3.8)
+ rspec (2.6.0)
+ rspec-core (~> 2.6.0)
+ rspec-expectations (~> 2.6.0)
+ rspec-mocks (~> 2.6.0)
+ rspec-core (2.6.4)
+ rspec-expectations (2.6.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.6.0)
ruby-hmac (0.4.0)
shoulda (2.11.3)
- sqlite3-ruby (1.3.2)
+ sqlite3 (1.3.3)
+ sqlite3-ruby (1.3.3)
+ sqlite3 (>= 1.3.3)
+ term-ansicolor (1.0.6)
thor (0.14.6)
treetop (1.4.9)
polyglot (>= 0.3.1)
- tzinfo (0.3.23)
- xml-simple (1.0.12)
+ tzinfo (0.3.29)
+ xml-simple (1.1.0)
PLATFORMS
ruby
@@ -104,7 +140,7 @@ DEPENDENCIES
fog
mime-types
mocha
- rails (~> 3.0.0)
+ rails (~> 3.0.9)
rake
rdoc
shoulda
View
2 gemfiles/rails3_1.gemfile
@@ -13,5 +13,5 @@ gem "bundler"
gem "cocaine"
gem "mime-types"
gem "rdoc", :require=>false
-gem "rails", "~>3.1.0.rc1"
+gem "rails", "~> 3.1.0.rc4"
View
125 gemfiles/rails3_1.gemfile.lock
@@ -1,62 +1,84 @@
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.1.0.rc1)
- actionpack (= 3.1.0.rc1)
+ actionmailer (3.1.0.rc4)
+ actionpack (= 3.1.0.rc4)
mail (~> 2.3.0)
- actionpack (3.1.0.rc1)
- activemodel (= 3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
+ actionpack (3.1.0.rc4)
+ activemodel (= 3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
builder (~> 3.0.0)
erubis (~> 2.7.0)
- i18n (~> 0.6.0beta1)
- rack (~> 1.3.0.beta2)
+ i18n (~> 0.6)
+ rack (~> 1.3.0)
rack-cache (~> 1.0.1)
rack-mount (~> 0.8.1)
rack-test (~> 0.6.0)
- sprockets (~> 2.0.0.beta.5)
+ sprockets (~> 2.0.0.beta.10)
tzinfo (~> 0.3.27)
- activemodel (3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
+ activemodel (3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
bcrypt-ruby (~> 2.1.4)
builder (~> 3.0.0)
- i18n (~> 0.6.0beta1)
- activerecord (3.1.0.rc1)
- activemodel (= 3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
+ i18n (~> 0.6)
+ activerecord (3.1.0.rc4)
+ activemodel (= 3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
arel (~> 2.1.1)
tzinfo (~> 0.3.27)
- activeresource (3.1.0.rc1)
- activemodel (= 3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
- activesupport (3.1.0.rc1)
+ activeresource (3.1.0.rc4)
+ activemodel (= 3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
+ activesupport (3.1.0.rc4)
multi_json (~> 1.0)
- appraisal (0.2.0)
+ appraisal (0.3.7)
+ aruba (~> 0.4.2)
bundler
rake
- arel (2.1.1)
+ arel (2.1.3)
+ aruba (0.4.3)
+ bcat (>= 0.6.1)
+ childprocess (>= 0.1.9)
+ cucumber (>= 0.10.7)
+ rdiscount (>= 1.6.8)
+ rspec (>= 2.6.0)
aws-s3 (0.6.2)
builder
mime-types
xml-simple
+ bcat (0.6.1)
+ rack (~> 1.0)
bcrypt-ruby (2.1.4)
builder (3.0.0)
- cocaine (0.0.2)
+ childprocess (0.2.0)
+ ffi (~> 1.0.6)
+ cocaine (0.1.0)
+ cucumber (1.0.2)
+ builder (>= 2.1.2)
+ diff-lcs (>= 1.1.2)
+ gherkin (~> 2.4.5)
+ json (>= 1.4.6)
+ term-ansicolor (>= 1.0.5)
+ diff-lcs (1.1.2)
erubis (2.7.0)
- excon (0.6.3)
- fog (0.8.1)
+ excon (0.6.5)
+ ffi (1.0.9)
+ fog (0.9.0)
builder
excon (~> 0.6.1)
formatador (>= 0.1.3)
json
mime-types
- net-ssh (>= 2.1.3)
+ net-scp (>= 1.0.4)
+ net-ssh (>= 2.1.4)
nokogiri (>= 1.4.4)
ruby-hmac
- formatador (0.1.4)
- hike (1.0.0)
+ formatador (0.2.0)
+ gherkin (2.4.5)
+ json (>= 1.4.6)
+ hike (1.2.0)
i18n (0.6.0)
- json (1.5.1)
+ json (1.5.3)
mail (2.3.0)
i18n (>= 0.4.0)
mime-types (~> 1.16)
@@ -64,10 +86,12 @@ GEM
mime-types (1.16)
mocha (0.9.12)
multi_json (1.0.3)
+ net-scp (1.0.4)
+ net-ssh (>= 1.99.1)
net-ssh (2.1.4)
- nokogiri (1.4.4)
+ nokogiri (1.5.0)
polyglot (0.3.1)
- rack (1.3.0)
+ rack (1.3.1)
rack-cache (1.0.2)
rack (>= 0.4)
rack-mount (0.8.1)
@@ -76,37 +100,48 @@ GEM
rack
rack-test (0.6.0)
rack (>= 1.0)
- rails (3.1.0.rc1)
- actionmailer (= 3.1.0.rc1)
- actionpack (= 3.1.0.rc1)
- activerecord (= 3.1.0.rc1)
- activeresource (= 3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
+ rails (3.1.0.rc4)
+ actionmailer (= 3.1.0.rc4)
+ actionpack (= 3.1.0.rc4)
+ activerecord (= 3.1.0.rc4)
+ activeresource (= 3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
bundler (~> 1.0)
- railties (= 3.1.0.rc1)
- railties (3.1.0.rc1)
- actionpack (= 3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
+ railties (= 3.1.0.rc4)
+ railties (3.1.0.rc4)
+ actionpack (= 3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
+ rdoc (~> 3.4)
thor (~> 0.14.6)
- rake (0.9.0)
+ rake (0.9.2)
+ rdiscount (1.6.8)
rdoc (3.8)
+ rspec (2.6.0)
+ rspec-core (~> 2.6.0)
+ rspec-expectations (~> 2.6.0)
+ rspec-mocks (~> 2.6.0)
+ rspec-core (2.6.4)
+ rspec-expectations (2.6.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.6.0)
ruby-hmac (0.4.0)
shoulda (2.11.3)
- sprockets (2.0.0.beta.8)
+ sprockets (2.0.0.beta.10)
hike (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
sqlite3 (1.3.3)
sqlite3-ruby (1.3.3)
sqlite3 (>= 1.3.3)
+ term-ansicolor (1.0.6)
thor (0.14.6)
- tilt (1.3.1)
+ tilt (1.3.2)
treetop (1.4.9)
polyglot (>= 0.3.1)
- tzinfo (0.3.27)
- xml-simple (1.0.15)
+ tzinfo (0.3.29)
+ xml-simple (1.1.0)
PLATFORMS
ruby
@@ -119,7 +154,7 @@ DEPENDENCIES
fog
mime-types
mocha
- rails (~> 3.1.0.rc1)
+ rails (~> 3.1.0.rc4)
rake
rdoc
shoulda

0 comments on commit 6cd951a

Please sign in to comment.
Something went wrong with that request. Please try again.