Permalink
Browse files

Shouldn't depend on activesupport =2.3.2

  • Loading branch information...
1 parent c455f5e commit 8327d9279273c011a7f825b956b26fdbd119fac6 @jyurek jyurek committed Apr 6, 2011
Showing with 1 addition and 1 deletion.
  1. +1 −1 paperclip.gemspec
View
@@ -26,7 +26,7 @@ spec = Gem::Specification.new do |s|
s.rdoc_options << '--line-numbers' << '--inline-source'
s.requirements << "ImageMagick"
s.add_dependency 'activerecord', '~>2.3.0'
- s.add_dependency 'activesupport', '=2.3.2'
+ s.add_dependency 'activesupport', '~>2.3.2'
s.add_development_dependency 'shoulda'
s.add_development_dependency 'appraisal'
s.add_development_dependency 'mocha'

2 comments on commit 8327d92

Just noticed that paperclip doesn't have a rails3 branch anymore, restricting activesupport and activerecord to 2.3 makes it only Rails 2.3 compatible. Am I missing something?

Member

jyurek replied Apr 6, 2011

The "=2.3.2" was in the rails3 branch as well. But you're right, I did this wrong, and I don't actually want ~> there, as it will prevent rails 3 installations. I think people had just had Rails 2.3 on their systems for the most part, which is why this didn't happen before.

Please sign in to comment.