String based terminators deprecation with rails 4.1.0.beta1 #1403

Closed
rahul-sekhar opened this Issue Dec 20, 2013 · 3 comments

Projects

None yet

3 participants

@rahul-sekhar

On upgrading to rails 4.1.0.beta1, I get:

DEPRECATION WARNING: String based terminators are deprecated, please use a lambda.

for each use of has_attached_file

@jonahbron
Contributor

I'm seeing this as well.

@jonahbron
Contributor

I've submitted a pull-request for this.

#1404

@jyurek
Member
jyurek commented Jan 2, 2014

Further discussion of this should go in @jonahbron's PR, which he linked. Thanks for reporting this.

@jyurek jyurek closed this Jan 2, 2014
@kaosf kaosf added a commit to kaosf/paperclip-deprecation-warning that referenced this issue Jul 11, 2014
@kaosf kaosf Modify paperclip version from 4.2.0 to 3.5.4
It makes a warning message.

rake #=>
DEPRECATION WARNING: String based terminators are deprecated, please use
a lambda. (called from <class:Item> at
/some/where/app/app/models/item.rb:2)

ref.
  thoughtbot/paperclip#1403
  thoughtbot/paperclip#1404
  http://dev.mensfeld.pl/2014/05/upgrading-to-rails-4-1-from-rails-4-0-ruby-on-rails/
f9095fb
@kaosf kaosf added a commit to kaosf/paperclip-deprecation-warning that referenced this issue Jul 11, 2014
@kaosf kaosf Modify paperclip version from 4.2.0 to 3.5.4
It makes a warning message.

rake #=>
DEPRECATION WARNING: String based terminators are deprecated, please use
a lambda. (called from <class:Item> at
/some/where/app/app/models/item.rb:2)

ref.
  thoughtbot/paperclip#1403
  thoughtbot/paperclip#1404
  http://dev.mensfeld.pl/2014/05/upgrading-to-rails-4-1-from-rails-4-0-ruby-on-rails/
b9aa283
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment