paperclip 2.3.12 doesn't run on Rails 2.3.11 #504

Closed
ghazel opened this Issue Jun 30, 2011 · 2 comments

Projects

None yet

3 participants

@ghazel
ghazel commented Jun 30, 2011

I get undefined method 'has_attached_file' for #<Class:0xbef9938> on Rails 2.3.11. Paperclip 2.3.11 works fine.

@nbrew
nbrew commented Jun 30, 2011

Same here. Using 2.3.11 works without issue whereas 2.3.12 results in undefined method 'has_attached_file'

@nbrew
nbrew commented Jun 30, 2011

Reverting the removal of rails/init.rb appears to remedy the issue for me with rails 2.3.12 and master of paperclip. Contents of rails/init.rb:
require 'paperclip/railtie' Paperclip::Railtie.insert

@cpytel cpytel closed this in c67b0f7 Jun 30, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment